]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- updated to 2.5.4 (fixes #339901)
[packages/python-sqlite.git] / python-sqlite.spec
1
2 %define         module  sqlite
3
4 Summary:        A DB API v2.0 compatible interface to SQLite
5 Summary(pl.UTF-8):      Interfejs do SQLite kompatybilny z DB API v2.0
6 Name:           python-%{module}
7 Version:        2.5.4
8 Release:        1
9 License:        zlib/libpng
10 Group:          Development/Languages/Python
11 Source0:        http://oss.itsystementwicklung.de/download/pysqlite/2.5/%{version}/pysqlite-%{version}.tar.gz
12 # Source0-md5:  d165bdaf753870348018cee07ac1422c
13 URL:            http://www.pysqlite.org/
14 %pyrequires_eq  python-modules
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  sqlite3-devel >= 3.6.11
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is an extension module for the SQLite embedded relational
21 database. It tries to conform to the Python DB-API Spec v2 as far as
22 possible. One problem is that SQLite returns everything as text. This
23 is a result of SQLite's internal representation of data, however it
24 still may be possible to return data in the type specified by the
25 table definitions.
26
27 %description -l pl.UTF-8
28 Ten pakiet zawiera moduł rozszerzenia dla osadzalnej relacyjnej bazy
29 danych SQLite. Próbuje on być w zgodzie ze specyfikacją Python DB-API
30 v2 na tyle, na ile to możliwe. Jednym problemem jest to, że SQLite
31 zwraca wszystko jako tekst. Jest to wynik wewnętrznej reprezentacji
32 danych przez SQLite; mimo to nadal jest możliwe zwracanie danych typu
33 podanego w definicji tabeli.
34
35 %prep
36 %setup -q -n pysqlite-%{version}
37
38 %build
39 CFLAGS="%{rpmcflags}"
40 export CFLAGS
41 python setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
46
47 PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir} \
48         python setup.py install \
49         --root=$RPM_BUILD_ROOT --optimize=2
50
51 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/{,test/}*.py \
52         $RPM_BUILD_ROOT%{_prefix}/pysqlite2-doc
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc doc/*.txt
60 %dir %{py_sitedir}/pysqlite2
61 %{py_sitedir}/*.egg-info
62 %{py_sitedir}/pysqlite2/*.py[co]
63 %attr(755,root,root) %{py_sitedir}/pysqlite2/_%{module}.so
64 %dir %{py_sitedir}/pysqlite2/test
65 %{py_sitedir}/pysqlite2/test/*.py[co]
This page took 0.086511 seconds and 4 git commands to generate.