]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- 2.3.3
[packages/python-sqlite.git] / python-sqlite.spec
1
2 %define         module  sqlite
3
4 Summary:        A DB API v2.0 compatible interface to SQLite
5 Summary(pl.UTF-8):      Interfejs do SQLite kompatybilny z DB API v2.0
6 Name:           python-%{module}
7 Version:        2.3.3
8 Release:        1
9 License:        zlib/libpng
10 Group:          Development/Languages/Python
11 Source0:        http://initd.org/pub/software/pysqlite/releases/2.3/%{version}/pysqlite-%{version}.tar.gz
12 # Source0-md5:  cac3e827f22befff8b6302109c6eff34
13 URL:            http://www.pysqlite.org/
14 %pyrequires_eq  python-modules
15 BuildRequires:  python-devel >= 1:2.3
16 BuildRequires:  sqlite3-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is an extension module for the SQLite embedded relational
21 database. It tries to conform to the Python DB-API Spec v2 as far as
22 possible. One problem is that SQLite returns everything as text. This
23 is a result of SQLite's internal representation of data, however it
24 still may be possible to return data in the type specified by the
25 table definitions.
26
27 %description -l pl.UTF-8
28 Ten pakiet zawiera moduł rozszerzenia dla osadzalnej relacyjnej bazy
29 danych SQLite. Próbuje on być w zgodzie ze specyfikacją Python DB-API
30 v2 na tyle, na ile to możliwe. Jednym problemem jest to, że SQLite
31 zwraca wszystko jako tekst. Jest to wynik wewnętrznej reprezentacji
32 danych przez SQLite; mimo to nadal jest możliwe zwracanie danych typu
33 podanego w definicji tabeli.
34
35 %prep
36 %setup -q -n pysqlite-%{version}
37
38 %build
39 CFLAGS="%{rpmcflags}"
40 export CFLAGS
41 python setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
46
47 PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir} \
48         python setup.py install \
49         --root=$RPM_BUILD_ROOT --optimize=2
50
51 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/{,test/}*.py \
52         $RPM_BUILD_ROOT%{_prefix}/pysqlite2-doc
53 cp -aR doc/code/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc doc/*.txt
61 %dir %{py_sitedir}/pysqlite2
62 %{py_sitedir}/pysqlite2/*.py[co]
63 %attr(755,root,root) %{py_sitedir}/pysqlite2/_%{module}.so
64 %dir %{py_sitedir}/pysqlite2/test
65 %{py_sitedir}/pysqlite2/test/*.py[co]
66 %dir %{_examplesdir}/%{name}-%{version}
67 %{_examplesdir}/%{name}-%{version}/*
This page took 0.058356 seconds and 4 git commands to generate.