]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- Release 4. Ac rebuild with changed Pythons ABI.
[packages/python-sqlite.git] / python-sqlite.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         module sqlite
4
5 Summary:        A DB API v2.0 compatible interface to SQLite
6 Summary(pl):    Interfejs do SQLite kompatybilny z DB API v2.0
7 Name:           python-%{module}
8 Version:        0.4.3
9 Release:        4
10 License:        Free
11 Group:          Development/Languages/Python
12 Source0:        http://dl.sourceforge.net/pysqlite/pysqlite-%{version}.tar.gz
13 # Source0-md5:  a55ae9b6f1968a5fe0df10731a5b5a7c
14 URL:            http://pysqlite.sourceforge.net/
15 %pyrequires_eq  python-modules
16 BuildRequires:  python-devel >= 2.3
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  sqlite-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is an extension module for the SQLite embedded relational
23 database. It tries to conform to the Python DB-API Spec v2 as far as
24 possible. One problem is that SQLite returns everything as text. This
25 is a result of SQLite's internal representation of data, however it
26 still may be possible to return data in the type specified by the
27 table definitions.
28
29 %description -l pl
30 Ten pakiet zawiera modu³ rozszerzenia dla osadzalnej relacyjnej bazy
31 danych SQLite. Próbuje on byæ w zgodzie ze specyfikacj± Python DB-API
32 v2 na tyle, na ile to mo¿liwe. Jednym problemem jest to, ¿e SQLite
33 zwraca wszystko jako tekst. Jest to wynik wewnêtrznej reprezentacji
34 danych przez SQLite; mimo to nadal jest mo¿liwe zwracanie danych typu
35 podanego w definicji tabeli.
36
37 %prep
38 %setup -q -n pysqlite-%{version}
39
40 %build
41 CFLAGS="%{rpmcflags}"
42 export CLFAGS
43 python setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
48
49 python setup.py install \
50         --root=$RPM_BUILD_ROOT --optimize=2
51
52 rm -f $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*.py
53 find examples -name CVS -print | xargs rm -r
54 cp -aR examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README LICENSE
62 %dir %{py_sitedir}/%{module}
63 %{py_sitedir}/%{module}/*.py[co]
64 %dir %{_examplesdir}/%{name}-%{version}
65 %{_examplesdir}/%{name}-%{version}/*
66 %attr(755,root,root) %{py_sitedir}/_%{module}.so
This page took 0.026104 seconds and 3 git commands to generate.