]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- mass commit: remove obsolete BR: rpm-pythonprov
[packages/python-sqlite.git] / python-sqlite.spec
1
2 %define         module  sqlite
3
4 Summary:        A DB API v2.0 compatible interface to SQLite
5 Summary(pl):    Interfejs do SQLite kompatybilny z DB API v2.0
6 Name:           python-%{module}
7 Version:        1.1.1
8 Release:        3
9 License:        Free
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/pysqlite/pysqlite-%{version}.tar.gz
12 # Source0-md5:  b95fe36298288171fae227b67bfc09ac
13 URL:            http://pysqlite.sourceforge.net/
14 %pyrequires_eq  python-modules
15 BuildRequires:  python-devel >= 1:2.3
16 BuildRequires:  sqlite3-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is an extension module for the SQLite embedded relational
21 database. It tries to conform to the Python DB-API Spec v2 as far as
22 possible. One problem is that SQLite returns everything as text. This
23 is a result of SQLite's internal representation of data, however it
24 still may be possible to return data in the type specified by the
25 table definitions.
26
27 %description -l pl
28 Ten pakiet zawiera modu³ rozszerzenia dla osadzalnej relacyjnej bazy
29 danych SQLite. Próbuje on byæ w zgodzie ze specyfikacj± Python DB-API
30 v2 na tyle, na ile to mo¿liwe. Jednym problemem jest to, ¿e SQLite
31 zwraca wszystko jako tekst. Jest to wynik wewnêtrznej reprezentacji
32 danych przez SQLite; mimo to nadal jest mo¿liwe zwracanie danych typu
33 podanego w definicji tabeli.
34
35 %prep
36 %setup -q -n pysqlite
37
38 %build
39 CFLAGS="%{rpmcflags}"
40 export CFLAGS
41 python setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
46
47 python setup.py install \
48         --root=$RPM_BUILD_ROOT --optimize=2
49
50 rm -f $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*.py
51 cp -aR examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README LICENSE doc/rest/manual.txt
59 %dir %{py_sitedir}/%{module}
60 %{py_sitedir}/%{module}/*.py[co]
61 %dir %{_examplesdir}/%{name}-%{version}
62 %{_examplesdir}/%{name}-%{version}/*
63 %attr(755,root,root) %{py_sitedir}/_%{module}.so
This page took 0.082702 seconds and 3 git commands to generate.