]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- spaces->tabs
[packages/python-sqlite.git] / python-sqlite.spec
1
2 %define         module  sqlite
3
4 Summary:        A DB API v2.0 compatible interface to SQLite
5 Summary(pl):    Interfejs do SQLite kompatybilny z DB API v2.0
6 Name:           python-%{module}
7 Version:        1.1.1
8 Release:        1
9 License:        Free
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/pysqlite/pysqlite-%{version}.tar.gz
12 # Source0-md5:  b95fe36298288171fae227b67bfc09ac
13 URL:            http://pysqlite.sourceforge.net/
14 %pyrequires_eq  python-modules
15 BuildRequires:  python-devel >= 2.3
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  sqlite-devel >= 3.0.0
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is an extension module for the SQLite embedded relational
22 database. It tries to conform to the Python DB-API Spec v2 as far as
23 possible. One problem is that SQLite returns everything as text. This
24 is a result of SQLite's internal representation of data, however it
25 still may be possible to return data in the type specified by the
26 table definitions.
27
28 %description -l pl
29 Ten pakiet zawiera modu³ rozszerzenia dla osadzalnej relacyjnej bazy
30 danych SQLite. Próbuje on byæ w zgodzie ze specyfikacj± Python DB-API
31 v2 na tyle, na ile to mo¿liwe. Jednym problemem jest to, ¿e SQLite
32 zwraca wszystko jako tekst. Jest to wynik wewnêtrznej reprezentacji
33 danych przez SQLite; mimo to nadal jest mo¿liwe zwracanie danych typu
34 podanego w definicji tabeli.
35
36 %prep
37 %setup -q -n pysqlite
38
39 %build
40 CFLAGS="%{rpmcflags}"
41 export CFLAGS
42 python setup.py build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
47
48 python setup.py install \
49         --root=$RPM_BUILD_ROOT --optimize=2
50
51 rm -f $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*.py
52 cp -aR examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README LICENSE doc/rest/manual.txt
60 %dir %{py_sitedir}/%{module}
61 %{py_sitedir}/%{module}/*.py[co]
62 %dir %{_examplesdir}/%{name}-%{version}
63 %{_examplesdir}/%{name}-%{version}/*
64 %attr(755,root,root) %{py_sitedir}/_%{module}.so
This page took 0.073578 seconds and 3 git commands to generate.