]> git.pld-linux.org Git - packages/python-sqlite.git/blob - python-sqlite.spec
- release 2
[packages/python-sqlite.git] / python-sqlite.spec
1
2 %define         module  sqlite
3
4 Summary:        A DB API v2.0 compatible interface to SQLite
5 Summary(pl.UTF-8):      Interfejs do SQLite kompatybilny z DB API v2.0
6 Name:           python-%{module}
7 Version:        2.6.0
8 Release:        2
9 License:        zlib/libpng
10 Group:          Development/Languages/Python
11 Source0:        http://pysqlite.googlecode.com/files/pysqlite-%{version}.tar.gz
12 # Source0-md5:  fc92618b3b39d02e6ff10dc467c36640
13 URL:            http://pysqlite.googlecode.com/
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  sqlite3-devel >= 3.6.11
16 %pyrequires_eq  python-modules
17 Provides:       python(sqlite)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is an extension module for the SQLite embedded relational
22 database. It tries to conform to the Python DB-API Spec v2 as far as
23 possible. One problem is that SQLite returns everything as text. This
24 is a result of SQLite's internal representation of data, however it
25 still may be possible to return data in the type specified by the
26 table definitions.
27
28 %description -l pl.UTF-8
29 Ten pakiet zawiera moduł rozszerzenia dla osadzalnej relacyjnej bazy
30 danych SQLite. Próbuje on być w zgodzie ze specyfikacją Python DB-API
31 v2 na tyle, na ile to możliwe. Jednym problemem jest to, że SQLite
32 zwraca wszystko jako tekst. Jest to wynik wewnętrznej reprezentacji
33 danych przez SQLite; mimo to nadal jest możliwe zwracanie danych typu
34 podanego w definicji tabeli.
35
36 %prep
37 %setup -q -n pysqlite-%{version}
38
39 %build
40 CFLAGS="%{rpmcflags}"
41 export CFLAGS
42 python setup.py build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
47
48 PYTHONPATH=$RPM_BUILD_ROOT%{py_sitedir} \
49         python setup.py install \
50         --root=$RPM_BUILD_ROOT --optimize=2
51
52 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/pysqlite2/{,test/}*.py \
53         $RPM_BUILD_ROOT%{_prefix}/pysqlite2-doc
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc doc/*.txt
61 %dir %{py_sitedir}/pysqlite2
62 %{py_sitedir}/*.egg-info
63 %{py_sitedir}/pysqlite2/*.py[co]
64 %attr(755,root,root) %{py_sitedir}/pysqlite2/_%{module}.so
65 %dir %{py_sitedir}/pysqlite2/test
66 %{py_sitedir}/pysqlite2/test/*.py[co]
This page took 0.056236 seconds and 3 git commands to generate.