]> git.pld-linux.org Git - packages/python-sqlalchemy-migrate.git/blob - python-sqlalchemy-migrate.spec
- updated to 1.13.0, finished packaging
[packages/python-sqlalchemy-migrate.git] / python-sqlalchemy-migrate.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (incomplete dependencies)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 Summary:        Schema migration tools for SQLAlchemy
9 Summary(pl.UTF-8):      Narzędzia do migracji struktury bazy dla SQLAlchemy
10 Name:           python-sqlalchemy-migrate
11 Version:        0.13.0
12 Release:        1
13 License:        MIT
14 Group:          Development/Languages/Python
15 Source0:        https://files.pythonhosted.org/packages/source/s/sqlalchemy-migrate/sqlalchemy-migrate-%{version}.tar.gz
16 # Source0-md5:  86572c92ae84334907f5e3a2cecc92a6
17 URL:            https://pypi.org/project/sqlalchemy-migrate/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-pbr >= 1.8
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-Tempita >= 0.4
24 BuildRequires:  python-decorator
25 BuildRequires:  python-ibm_db_sa
26 BuildRequires:  python-scripttest
27 BuildRequires:  python-six >= 1.7.0
28 BuildRequires:  python-sqlalchemy >= 0.9.6
29 BuildRequires:  python-sqlparse
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-modules >= 1:3.3
34 BuildRequires:  python3-pbr >= 1.8
35 BuildRequires:  python3-setuptools
36 %if %{with tests}
37 BuildRequires:  python3-Tempita >= 0.4
38 BuildRequires:  python3-decorator
39 BuildRequires:  python3-ibm_db_sa
40 BuildRequires:  python3-scripttest
41 BuildRequires:  python3-six >= 1.7.0
42 BuildRequires:  python3-sqlalchemy >= 0.9.6
43 BuildRequires:  python3-sqlparse
44 %endif
45 %endif
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.714
48 %if %{with doc}
49 BuildRequires:  sphinx-pdg-2 >= 1.6.7
50 %endif
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Schema migration tools for SQLAlchemy, designed to support an agile
56 approach to database design, and make it easier to keep development
57 and production databases in sync, as schema changes are required.
58
59 %description -l pl.UTF-8
60 Narzędzia migracji struktury bazy danych dla SQLAlchemy,
61 zaprojektowane aby wspierać zwinne podejście do projektowania baz i
62 ułatwiać utrzymanie wersji rozwojowych i produkcyjnych baz danych w
63 synchronizacji w miarę zmian ich struktury.
64
65 %package -n python3-sqlalchemy-migrate
66 Summary:        Schema migration tools for SQLAlchemy
67 Summary(pl.UTF-8):      Narzędzia do migracji struktury bazy dla SQLAlchemy
68 Group:          Development/Languages/Python
69
70 %description -n python3-sqlalchemy-migrate
71 Schema migration tools for SQLAlchemy, designed to support an agile
72 approach to database design, and make it easier to keep development
73 and production databases in sync, as schema changes are required.
74
75 %description -n python3-sqlalchemy-migrate -l pl.UTF-8
76 Narzędzia migracji struktury bazy danych dla SQLAlchemy,
77 zaprojektowane aby wspierać zwinne podejście do projektowania baz i
78 ułatwiać utrzymanie wersji rozwojowych i produkcyjnych baz danych w
79 synchronizacji w miarę zmian ich struktury.
80
81 %package apidocs
82 Summary:        API documentation for Python SQLAlchemy Migrate module
83 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona SQLAlchemy Migrate
84 Group:          Documentation
85
86 %description apidocs
87 API documentation for Python SQLAlchemy Migrate module.
88
89 %description apidocs -l pl.UTF-8
90 Dokumentacja API modułu Pythona SQLAlchemy Migrate.
91
92 %prep
93 %setup -q -n sqlalchemy-migrate-%{version}
94
95 %build
96 %if %{with python2}
97 %py_build %{?with_tests:test}
98 %endif
99
100 %if %{with python3}
101 %py3_build %{?with_tests:test}
102 %endif
103
104 %if %{with doc}
105 PYTHONPATH=$(pwd) \
106 %{__make} -C doc/source html \
107         SPHINXBUILD=sphinx-build-2
108 %endif
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %if %{with python2}
114 %py_install
115
116 %py_postclean
117 %endif
118
119 %if %{with python3}
120 %py3_install
121 %endif
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %if %{with python2}
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS COPYING ChangeLog README.rst TODO
130 %attr(755,root,root) %{_bindir}/migrate
131 %attr(755,root,root) %{_bindir}/migrate-repository
132 %{py_sitescriptdir}/migrate
133 %{py_sitescriptdir}/sqlalchemy_migrate-%{version}-py*.egg-info
134 %endif
135
136 %if %{with python3}
137 %files -n python3-sqlalchemy-migrate
138 %defattr(644,root,root,755)
139 %doc AUTHORS COPYING ChangeLog README.rst TODO
140 %{py3_sitescriptdir}/migrate
141 %{py3_sitescriptdir}/sqlalchemy_migrate-%{version}-py*.egg-info
142 %endif
143
144 %if %{with doc}
145 %files apidocs
146 %defattr(644,root,root,755)
147 %doc doc/source/_build/html/{_static,*.html,*.js}
148 %endif
This page took 0.120085 seconds and 4 git commands to generate.