]> git.pld-linux.org Git - packages/python-slip.git/blob - python-slip.spec
- new, from fedora
[packages/python-slip.git] / python-slip.spec
1 # TODO
2 # - fix bashism: sh: >&/dev/null : illegal file descriptor name
3 Summary:        Miscellaneous convenience, extension and workaround code for Python
4 Name:           python-slip
5 Version:        0.2.20
6 Release:        2.3
7 License:        GPL v2+
8 Group:          Development/Languages/Python
9 URL:            http://fedorahosted.org/python-slip
10 Source0:        http://fedorahosted.org/released/python-slip/%{name}-%{version}.tar.bz2
11 # Source0-md5:  4e0267cbeb2cb1666c5930bd7c7acfb4
12 BuildRequires:  python
13 BuildRequires:  rpmbuild(macros) >= 1.219
14 BuildRequires:  python-devel
15 Requires:       python-selinux
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The Simple Library for Python packages contain miscellaneous code for
21 convenience, extension and workaround purposes.
22
23 This package provides the "slip" and the "slip.util" modules.
24
25 %package dbus
26 Summary:        Convenience functions for dbus services
27 Group:          Libraries
28 Requires:       %{name} = %{version}-%{release}
29 Requires:       polkit >= 0.94
30 Requires:       python-dbus >= 0.80
31 Requires:       python-decorator
32 Requires:       python-pygobject
33 Conflicts:      PolicyKit < 0.8-3
34
35 %description dbus
36 The Simple Library for Python packages contain miscellaneous code for
37 convenience, extension and workaround purposes.
38
39 This package provides slip.dbus.service.Object, which is a
40 dbus.service.Object derivative that ends itself after a certain time
41 without being used and/or if there are no clients anymore on the
42 message bus, as well as convenience functions and decorators for
43 integrating a dbus service with PolicyKit.
44
45 %package gtk
46 Summary:        Code to make auto-wrapping gtk labels
47 Group:          Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       python-pygtk-gtk
50
51 %description gtk
52 The Simple Library for Python packages contain miscellaneous code for
53 convenience, extension and workaround purposes.
54
55 This package provides slip.gtk.set_autowrap(), a convenience function
56 which lets Gtk labels be automatically re-wrapped upon resizing.
57
58 %prep
59 %setup -q
60
61 %build
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %py_postclean
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc COPYING doc/dbus
77 %dir %{py_sitescriptdir}/slip
78 %{py_sitescriptdir}/slip/__init__.py[co]
79 %{py_sitescriptdir}/slip/util
80 %{py_sitescriptdir}/slip-%{version}-py%{python_version}.egg-info
81
82 %files dbus
83 %defattr(644,root,root,755)
84 %doc doc/dbus/*
85 %{py_sitescriptdir}/slip/dbus
86 %{py_sitescriptdir}/slip.dbus-%{version}-py%{python_version}.egg-info
87
88 %files gtk
89 %defattr(644,root,root,755)
90 %{py_sitescriptdir}/slip/gtk
91 %{py_sitescriptdir}/slip.gtk-%{version}-py%{python_version}.egg-info
This page took 0.06438 seconds and 4 git commands to generate.