]> git.pld-linux.org Git - packages/python-simpleparse.git/blob - python-simpleparse.spec
- BR unzip
[packages/python-simpleparse.git] / python-simpleparse.spec
1 %define         module          simpleparse
2 %define         cap_name        SimpleParse
3 Summary:        Python package providing a simple parser generator for use with the mxTextTool
4 Summary(pl):    Pakiet zawieraj±cy prosty generator parserów dla mxTextTool
5 Name:           python-%{module}
6 Version:        2.0.1a3
7 Release:        1
8 License:        BSD
9 Group:          Development/Languages/Python
10 Source0:        http://dl.sourceforge.net/%{module}/%{cap_name}-%{version}.zip
11 # Source0-md5:  dffa19a7a21d342d56c3d1bf391c2c2d
12 URL:            http://simpleparse.sourceforge.net/
13 BuildRequires:  unzip
14 Requires:       python-mx-TextTools >= 2.0
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 SimpleParse allows you to generate tagging tables for use with the
19 text-tagging engine directly from your EBNF grammar.
20
21 %description -l pl
22 SimpleParse pozwala na generowanie tabeli taguj±cych do u¿ytku z
23 silnikiem taguj±cym tekst bezpo¶rednio z gramatyk EBNF.
24
25 %prep
26 %setup -q -n %{cap_name}-%{version}
27
28 %build
29 python setup.py build
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT%{py_sitedir}
34
35 python setup.py install \
36         --root=$RPM_BUILD_ROOT --optimize=2
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43
44 %doc %{module}/doc %{module}/examples
45 %dir %{py_sitescriptdir}/%{module}
46 %{py_sitescriptdir}/%{module}/*.py[co]
47 %dir %{py_sitescriptdir}/%{module}/common
48 %{py_sitescriptdir}/%{module}/common/*.py[co]
49 %dir %{py_sitescriptdir}/%{module}/xml
50 %{py_sitescriptdir}/%{module}/xml/*.py[co]
This page took 0.154803 seconds and 4 git commands to generate.