]> git.pld-linux.org Git - packages/python-simplejson.git/blob - python-simplejson.spec
- Version 2.0.3-1. Copied from HEAD.
[packages/python-simplejson.git] / python-simplejson.spec
1 # TODO: optflags
2 %define         module          simplejson
3 Summary:        Simple, fast, extensible JSON encoder/decoder for Python
4 Summary(pl.UTF-8):      Prosty, szybki, rozszerzalny (de)koder JSON dla Pythona
5 Name:           python-%{module}
6 Version:        2.0.3
7 Release:        1
8 License:        MIT
9 Group:          Libraries
10 Source0:        http://pypi.python.org/packages/source/s/%{module}/%{module}-%{version}.tar.gz
11 # Source0-md5:  6da5d665c9e772ac65eae9b4ce6d737b
12 URL:            http://undefined.org/python/#simplejson
13 BuildRequires:  python >= 1:2.4
14 BuildRequires:  python-setuptools >= 0.6-0.c1
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-libs
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 simplejson is a simple, fast, complete, correct and extensible JSON
21 <http://json.org/> encoder and decoder for Python 2.4+.
22
23 %description -l pl.UTF-8
24 simplejson to prosty, szybki, pełny, poprawny i rozszerzalny koder i
25 dekoder JSON (<http://json.org/>) dla Pythona 2.4 i nowszych wersji.
26
27 %prep
28 %setup -qn %{module}-%{version}
29
30 %build
31 %{__python} setup.py build
32         
33 %install
34 rm -rf $RPM_BUILD_ROOT
35
36 %{__python} setup.py install \
37         --root=$RPM_BUILD_ROOT \
38         --optimize=2
39
40 %py_postclean
41 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/simplejson/tests
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %dir %{py_sitedir}/simplejson
49 %{py_sitedir}/simplejson/*.py[co]
50 %attr(755,root,root) %{py_sitedir}/simplejson/*.so
51 %{py_sitedir}/simplejson-%{version}-py*.egg-info
This page took 0.048229 seconds and 3 git commands to generate.