]> git.pld-linux.org Git - packages/python-sh.git/blob - python-sh.spec
- release 3 (by relup.sh)
[packages/python-sh.git] / python-sh.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          sh
7 %define         egg_name        sh
8 %define         pypi_name       sh
9 Summary:        Python subprocess interface
10 Name:           python-%{module}
11 Version:        1.11
12 Release:        3
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        https://files.pythonhosted.org/packages/source/s/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  7af8df6c92d29ff927b6db0146bddec3
17 URL:            https://amoffat.github.io/sh/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules
26 BuildRequires:  python3-setuptools
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 sh (previously pbs) is a full-fledged subprocess replacement for
33 Python 2.6 - 3.4 that allows you to call any program as if it were a
34 function
35
36 %package -n python3-%{module}
37 Summary:        SH module for python 3
38 Summary(pl.UTF-8):      ModuĊ‚ sh dla pythona 3
39 Group:          Libraries/Python
40
41 %description -n python3-%{module}
42 sh (previously pbs) is a full-fledged subprocess replacement for
43 Python 2.6 - 3.4 that allows you to call any program as if it were a
44 function
45
46 %prep
47 %setup -q -n %{module}-%{version}
48
49 %build
50 %if %{with python2}
51 %py_build
52 %endif
53
54 %if %{with python3}
55 %py3_build
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %if %{with python2}
61 %py_install
62 %py_postclean
63 %endif
64
65 %if %{with python3}
66 %py3_install
67 %endif
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with python2}
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS.md CHANGELOG.md README.md
76 %{py_sitescriptdir}/%{module}.py[co]
77 %{py_sitescriptdir}/%{egg_name}-*-py*.egg-info
78 %endif
79
80 %if %{with python3}
81 %files -n python3-%{module}
82 %defattr(644,root,root,755)
83 %doc AUTHORS.md CHANGELOG.md README.md
84 %{py3_sitescriptdir}/__pycache__/%{module}.*.pyc
85 %{py3_sitescriptdir}/%{module}.py
86 %{py3_sitescriptdir}/%{egg_name}-*-py*.egg-info
87 %endif
This page took 0.055748 seconds and 3 git commands to generate.