]> git.pld-linux.org Git - packages/python3-setuptools.git/blob - python-setuptools.spec
6e96a4a57606dfd7c0469c30573ebf3a6dc5eafc
[packages/python3-setuptools.git] / python-setuptools.spec
1
2 %define module  setuptools
3
4 Summary:        A collection of enhancements to the Python distutils
5 Summary(pl):    Zestaw rozszerzeñ dla pythonowych distutils
6 Name:           python-setuptools
7 Version:        0.6a10
8 Release:        1
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.zip
12 # Source0-md5:  8bcf7524d484aa3134a1b5aa64d2c275
13 URL:            http://peak.telecommunity.com/DevCenter/setuptools
14 BuildRequires:  findutils
15 %pyrequires_eq  python
16 BuildRequires:  python-devel
17 BuildRequires:  unzip
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 setuptools is a collection of enhancements to the Python distutils
23 (for Python 2.3.5 and up on most platforms; 64-bit platforms require a
24 minimum of Python 2.4) that allow you to more easily build and
25 distribute Python packages, especially ones that have dependencies on
26 other packages.
27
28 %description -l pl
29 setuptools to zestaw rozszerzeñ do pythonowych distutils (dla Pythona
30 2.3.5 i nowszego na wiêkszo¶ci platform; platformy 64-bitowe wymagaj±
31 co najmniej Pythona 2.4) umo¿liwiaj±cy ³atwiejsze budowanie i
32 rozprowadzanie pakietów Pythona, szczególnie tych maj±cych zale¿no¶ci
33 od innych pakietów.
34
35 %prep
36 %setup  -q -n %{module}-%{version}
37
38 %build
39 python ./setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 python ./setup.py install \
45         --single-version-externally-managed \
46         --optimize 2 \
47         --root=$RPM_BUILD_ROOT
48
49 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
50
51 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
52 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
53 %py_postclean
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc *.txt
61 %attr(755,root,root) %{_bindir}/*
62 %{py_sitescriptdir}/%{module}*
63 %{py_sitescriptdir}/*.py[co]
This page took 0.072667 seconds and 2 git commands to generate.