]> git.pld-linux.org Git - SPECS.git/blob - python-satchmo.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python-satchmo.spec
1 %define         module  satchmo
2
3 Summary:        The web shop for perfectionists with deadlines
4 Summary(pl.UTF-8):      Sklep WWW dla perfekcjonistów z ograniczeniami czasowymi
5 Name:           python-satchmo
6 Version:        0.8.1
7 Release:        0.1
8 License:        BSD
9 Group:          Development/Languages/Python
10 Source0:        http://satchmoproject.com/snapshots/%{module}-%{version}.tar.gz
11 # Source0-md5:  3e7f13edfc717d88f754f475182072d6
12 URL:            http://www.satchmoproject.com/
13 BuildRequires:  rpmbuild(macros) >= 1.714
14 BuildRequires:  python-devel
15 BuildRequires:  python-setuptools >= 1:0.6-0.c1
16 BuildRequires:  rpm-pythonprov
17 Requires:       python-django = 0.96
18 %pyrequires_eq  python
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Satchmo is a web shop based on Django framework.
24
25 %description -l pl.UTF-8
26 Satchmo to sklep internetowy oparty na szkielecie Django.
27
28 %prep
29 %setup -q -n %{module}-%{version}
30
31 %build
32 %py_build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 %py_install
38
39 find $RPM_BUILD_ROOT -type f -name '*.pyc' -exec rm "{}" ";"
40 find $RPM_BUILD_ROOT -type f -name '*.pyo' -exec rm "{}" ";"
41 find $RPM_BUILD_ROOT -type f -exec sed -i -e "s#$RPM_BUILD_ROOT##g" "{}" ";"
42
43 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
44 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
45 # %%py_postclean
46 find $RPM_BUILD_ROOT%{py_sitescriptdir} -type f -name '*.py' -a -not -path '*_template*' -exec rm "{}" ";"
47 find $RPM_BUILD_ROOT%{py_sitescriptdir} -type f -path '*_template*' -a -name '*.py[oc]' -exec rm "{}" ";"
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc docs/*.*
55 %{py_sitescriptdir}/%{module}*
56 %{py_sitescriptdir}/Satchmo-*.egg-info
This page took 0.202322 seconds and 3 git commands to generate.