]> git.pld-linux.org Git - SPECS.git/blob - python-rpdb.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-rpdb.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5
6 %define module  rpdb
7 Summary:        pdb wrapper with remote access via tcp socket
8 Name:           python-rpdb
9 Version:        0.1.3
10 Release:        9
11 License:        ?
12 Group:          Development/Languages/Python
13 Source0:        https://pypi.python.org/packages/source/r/rpdb/rpdb-%{version}.tar.gz
14 # Source0-md5:  4f350f523446a9100395d41b0b05c6cb
15 URL:            https://pypi.python.org/pypi/rpdb/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 %if %{with python2}
19 BuildRequires:  python-devel
20 BuildRequires:  python-modules
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-2to3
24 BuildRequires:  python3-devel
25 BuildRequires:  python3-modules
26 %endif
27 Requires:       python
28 Requires:       python-devel-src
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 A wrapper around pdb that will re-route stdin and stdout to a socket
34 handler.
35
36 %package -n python3-%{module}
37 Summary:        pdb wrapper with remote access via tcp socket
38 Group:          Libraries/Python
39 Requires:       python3
40 Requires:       python3-devel-tools
41
42 %description -n python3-%{module}
43 A wrapper around pdb that will re-route stdin and stdout to a socket
44 handler.
45
46 %prep
47 %setup  -q -n %{module}-%{version}
48
49 %build
50 %if %{with python2}
51 %py_build
52 %endif
53 %if %{with python3}
54 %py3_build
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %if %{with python2}
60 %py_install
61
62 %py_postclean
63 %endif
64
65 %if %{with python3}
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
67 %py3_install
68 %endif
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %files
75 %defattr(644,root,root,755)
76 %doc PKG-INFO
77 %{py_sitescriptdir}/rpdb
78 %{py_sitescriptdir}/rpdb-%{version}-py*.egg-info
79 %endif
80
81 %if %{with python3}
82 %files -n python3-%{module}
83 %defattr(644,root,root,755)
84 %doc PKG-INFO
85 %{py3_sitescriptdir}/rpdb
86 %{py3_sitescriptdir}/rpdb-%{version}-py*.egg-info
87 %endif
This page took 0.300163 seconds and 3 git commands to generate.