]> git.pld-linux.org Git - SPECS.git/blob - python-pytest-httpbin.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / python-pytest-httpbin.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        py.test plugin to test HTTP libraries against a local copy of httpbin
7 Summary(pl.UTF-8):      Wtyczka py.test do testowania bibliotek HTTP względem lokalnej kopii httpbin
8 Name:           python-pytest-httpbin
9 Version:        0.2.3
10 Release:        4
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.python.org/simple/pytest-httpbin/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-httpbin/pytest-httpbin-%{version}.tar.gz
15 # Source0-md5:  b8ebb8e2fbac1a445fb5d044f7fec556
16 URL:            https://github.com/kevin1024/pytest-httpbin
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.6
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.4
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.6
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 py.test plugin to test HTTP libraries against a local copy of httpbin.
33
34 %description -l pl.UTF-8
35 Wtyczka py.test do testowania bibliotek HTTP względem lokalnej kopii
36 httpbin.
37
38 %package -n python3-pytest-httpbin
39 Summary:        py.test plugin to test HTTP libraries against a local copy of httpbin
40 Summary(pl.UTF-8):      Wtyczka py.test do testowania bibliotek HTTP względem lokalnej kopii httpbin
41 Group:          Libraries/Python
42 Requires:       python3-modules >= 1:3.4
43
44 %description -n python3-pytest-httpbin
45 py.test plugin to test HTTP libraries against a local copy of httpbin.
46
47 %description -n python3-pytest-httpbin -l pl.UTF-8
48 Wtyczka py.test do testowania bibliotek HTTP względem lokalnej kopii
49 httpbin.
50
51 %prep
52 %setup -q -n pytest-httpbin-%{version}
53
54 %build
55 %if %{with python2}
56 %py_build
57 %endif
58
59 %if %{with python3}
60 %py3_build
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %if %{with python2}
67 %py_install
68
69 %py_postclean -x version.py
70 %endif
71
72 %if %{with python3}
73 %py3_install
74 %endif
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %if %{with python2}
80 %files
81 %defattr(644,root,root,755)
82 %doc DESCRIPTION.rst
83 %{py_sitescriptdir}/pytest_httpbin
84 %{py_sitescriptdir}/pytest_httpbin-%{version}-py*.egg-info
85 %endif
86
87 %if %{with python3}
88 %files -n python3-pytest-httpbin
89 %defattr(644,root,root,755)
90 %doc DESCRIPTION.rst
91 %{py3_sitescriptdir}/pytest_httpbin
92 %{py3_sitescriptdir}/pytest_httpbin-%{version}-py*.egg-info
93 %endif
This page took 0.588232 seconds and 3 git commands to generate.