]> git.pld-linux.org Git - SPECS.git/blob - python-pyrad.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-pyrad.spec
1
2 %define         module  pyrad
3
4 Summary:        pyrad - Python implementation of a RADIUS client
5 Summary(pl.UTF-8):      pyrad - implementacja klienta RADIUS w Pythonie
6 Name:           python-%{module}
7 Version:        1.1
8 Release:        3
9 License:        BSD-like
10 Group:          Libraries/Python
11 Source0:        http://pypi.python.org/packages/source/p/pyrad/%{module}-%{version}.tar.gz
12 # Source0-md5:  ab1502f8ccd7409ced757d78b0dee7df
13 URL:            http://www.wiggy.net/code/pyrad/
14 BuildRequires:  python-devel >= 1:2.3
15 BuildRequires:  python-modules
16 BuildRequires:  python-setuptools
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python-libs
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 pyrad is an implementation of a RADIUS client as described in RFC2865.
25 It takes care of all the details like building RADIUS packets, sending
26 them and decoding responses.
27
28 %description -l pl.UTF-8
29 pyrad jest implementacją klienta protokołu RADIUS, opisanego w
30 dokumencie RFC2865. Moduł ten odpowiada za wszystkie aspekty
31 przetwarzania protokołu RADIUS, takie jak budowanie pakietów
32 protokołu, wysyłanie ich oraz odkodowywanie odpowiedzi.
33
34 %package examples
35 Summary:        Example programs for Python pyrad module
36 Summary(pl.UTF-8):      Programy przykładowe do modułu Pythona pyrad
37 Group:          Development/Languages/Python
38 Requires:       %{name} = %{version}-%{release}
39
40 %description examples
41 This package contains example programs for Python pyrad module.
42
43 %description examples -l pl.UTF-8
44 Pakiet zawierający programy przykładowe dla modułu Pythona pyrad.
45
46 %prep
47 %setup -q -n %{module}-%{version}
48
49 %build
50 python setup.py build_ext
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_examplesdir}/%{name}-%{version}}
55
56 %py_install \
57         --install-lib=%{py_sitescriptdir} \
58         --optimize=2
59 %py_postclean
60
61 cp -a example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README.txt
69 %{py_sitescriptdir}/pyrad
70 %{py_sitescriptdir}/%{module}-*.egg-info
71
72 %files examples
73 %defattr(644,root,root,755)
74 %{_examplesdir}/%{name}-%{version}
This page took 0.036256 seconds and 3 git commands to generate.