]> git.pld-linux.org Git - SPECS.git/blob - python-pyilmbase.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / python-pyilmbase.spec
1 Summary:        Python bindings for the IlmBase libraries
2 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek IlmBase
3 Name:           python-pyilmbase
4 Version:        2.3.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries/Python
8 #Source0Download: https://github.com/AcademySoftwareFoundation/openexr/releases
9 Source0:        https://github.com/AcademySoftwareFoundation/openexr/releases/download/v%{version}/pyilmbase-%{version}.tar.gz
10 # Source0-md5:  7ec7fef6f65594acd612bbe9fbefcea3
11 Patch0:         %{name}-link.patch
12 URL:            https://www.openexr.com/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake >= 1.6.3
15 BuildRequires:  boost-python-devel
16 BuildRequires:  ilmbase-devel >= 2.3.0
17 BuildRequires:  libstdc++-devel >= 6:5
18 BuildRequires:  libtool >= 2:1.5
19 BuildRequires:  pkgconfig
20 BuildRequires:  python-devel
21 BuildRequires:  python-numpy-devel
22 BuildRequires:  rpm-pythonprov
23 Requires:       ilmbase >= 2.3.0
24 Requires:       python-modules
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The PyIlmBase package provides python bindings for the IlmBase
29 libraries.
30
31 %description -l pl.UTF-8
32 Pakiet PyIlmBase dostarcza wiązania Pythona do bibliotek IlmBase.
33
34 %package devel
35 Summary:        Header files for IlmBase Python bindings
36 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Pyhona do bibliotek IlmBase
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       boost-python-devel
40 Requires:       ilmbase-devel >= 2.3.0
41 Requires:       libstdc++-devel >= 6:5
42
43 %description devel
44 Header files for IlmBase Python bindings.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe wiązań Pyhona do bibliotek IlmBase.
48
49 %prep
50 %setup -q -n pyilmbase-%{version}
51 %patch0 -p1
52
53 %build
54 %{__libtoolize}
55 %{__aclocal} -I m4
56 %{__autoconf}
57 %{__automake}
58 %configure \
59         --with-boost-python-libname=boost_python%(echo %{py_ver} | tr -d .)
60
61 # g++ eats a lot of memory, don't run many in parallel
62 %{__make} -j1
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 # parallel build fails at libPyImath/imathmodule install
68 %{__make} -j1 install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libPy*.la \
72         $RPM_BUILD_ROOT%{py_sitedir}/*.la
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc ChangeLog LICENSE README.md
80 %attr(755,root,root) %{_libdir}/libPyIex.so.*.*.*
81 %attr(755,root,root) %ghost %{_libdir}/libPyIex.so.24
82 %attr(755,root,root) %{_libdir}/libPyImath.so.*.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libPyImath.so.24
84 %attr(755,root,root) %{py_sitedir}/iexmodule.so
85 %attr(755,root,root) %{py_sitedir}/imathmodule.so
86 %attr(755,root,root) %{py_sitedir}/imathnumpymodule.so
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libPyIex.so
91 %attr(755,root,root) %{_libdir}/libPyImath.so
92 %{_includedir}/OpenEXR/PyIex*.h
93 %{_includedir}/OpenEXR/PyIlmBaseConfig.h
94 %{_includedir}/OpenEXR/PyImath*.h
95 %{_pkgconfigdir}/PyIlmBase.pc
96 %{_aclocaldir}/pyilmbase.m4
This page took 0.198971 seconds and 3 git commands to generate.