]> git.pld-linux.org Git - packages/python-pygtk.git/blob - python-pygtk.spec
- release up
[packages/python-pygtk.git] / python-pygtk.spec
1 %define module pygtk
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3
4 Summary:        GTK+ interface for Python language
5 Summary(pl):    Interfejs GTK+ dla jêzyka Python
6 Name:           python-%{module}
7 Version:        0.6.6
8 Release:        4
9 License:        LGPL
10 Group:          Development/Languages/Python
11 Group(pl):      Programowanie/Jêzyki/Python
12 Source:         %{module}-%{version}.tar.gz
13 Requires:       python >= 1.5, gtk+ >= 1.2.6, imlib >= 1.8
14 BuildRequires:  python-devel >= 1.5, gtk+-devel >= 1.2.6
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This archive contains modules that allow you to use gtk+ in Python
19 programs.
20
21 %description -l pl
22 Pakiet ten zawiera modu³y dla jêzyka Python umo¿liwiaj±ce tworzenie
23 programów z u¿yciem biblioteki GTK+.
24
25 %prep
26 %setup -q -n %{module}-%{version}
27
28 %build
29 %configure
30 %{__make} OPT="$RPM_OPT_FLAGS"
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 install -d $RPM_BUILD_ROOT%{python_sitepkgsdir}/%{module}
36
37 %{__make} install \
38         DESTDIR=$RPM_BUILD_ROOT \
39         pyexecdir=%{python_sitepkgsdir}/%{module} \
40         pthondir=%{python_sitepkgsdir}/%{module}
41         
42 install -d $RPM_BUILD_ROOT%{_prefix}/src/examples/%{name}
43 mv examples/* $RPM_BUILD_ROOT%{_prefix}/src/examples/%{name}
44
45 mv $RPM_BUILD_ROOT%{python_sitepkgsdir}/*.py* \
46         $RPM_BUILD_ROOT%{python_sitepkgsdir}/%{module}
47
48 echo %{module} > $RPM_BUILD_ROOT%{python_sitepkgsdir}/%{module}.pth
49 echo pyglade > $RPM_BUILD_ROOT%{python_sitepkgsdir}/pyglade.pth
50
51 gzip -9nf COPYING ChangeLog README MAPPING
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc {ChangeLog,README,MAPPING}.gz
59 %{python_sitepkgsdir}/%{module}.pth
60 %{python_sitepkgsdir}/%{module}
61 %{python_sitepkgsdir}/pyglade.pth
62 %{python_sitepkgsdir}/pyglade
63 %{_includedir}/%{module}/
64 %attr(-,root,root) %{_prefix}/src/examples/%{name}
This page took 0.031228 seconds and 3 git commands to generate.