]> git.pld-linux.org Git - SPECS.git/blob - python-pygame2.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-pygame2.spec
1 #
2 # TODO: - unpackaged files:
3 #               _site-packages/pygame/dll/*
4 #               _site-packages/pygame/examples/*
5 #               _site-packages/pygame/freetype/*
6 #               _site-packages/pygame/sdl/*
7 #               _site-packages/pygame/sdltext/*
8 #               _site-packages/pygame/sdlglx/*
9 #               _site-packages/pygame/sdlimage/*
10 #               _site-packages/pygame/sdlmixer/*
11 #               _site-packages/pygame/sdlttf/*
12 #               _site-packages/pygame/sprite/*
13 #               _site-packages/pygame/test/*
14 #
15
16 %define         module  pygame2
17 %define         _alpha  alpha5
18
19 Summary:        Python modules designed for writing games
20 Summary(pl.UTF-8):      Moduły Pythona dla piszących gry
21 Name:           python-%{module}
22 Version:        2.0.0
23 Release:        0.%{_alpha}.1
24 License:        LGPL v2.1+
25 Group:          Libraries/Python
26 Source0:        http://pgreloaded.googlecode.com/files/%{module}-%{version}-%{_alpha}.tar.gz
27 # Source0-md5:  9b79ae86fddb613e08cbdc8bc8b96a56
28 URL:            http://www.pygame.org/
29 BuildRequires:  SDL-devel
30 BuildRequires:  SDL_gfx-devel
31 BuildRequires:  SDL_image-devel
32 BuildRequires:  SDL_mixer-devel >= 1.2.10
33 BuildRequires:  SDL_ttf-devel >= 2.0
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  portmidi-devel
37 BuildRequires:  python-numpy-devel
38 BuildRequires:  python-devel >= 2.2.1
39 BuildRequires:  python-modules
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.710
42 BuildRequires:  smpeg-devel
43 Obsoletes:      python-pygame
44 %pyrequires_eq  python
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Pygame is a set of Python modules designed for writing games. It is
49 written on top of the excellent SDL library. This allows you to create
50 fully featured games and multimedia programs in the python language.
51 The package is highly portable, with games running on Windows, NT4,
52 MacOS, OSX, BeOS, FreeBSD, IRIX, and Linux.
53
54 %description -l pl.UTF-8
55 Pygame jest zbiorem modułów Pythona zaprojektowanych do pisania gier.
56 Moduły te zostały napisane na bazie wspaniałej biblioteki SDL. Dzięki
57 temu możliwe jest tworzenie bogatych w multimedia gier w języku
58 Python.
59
60 %package devel
61 Summary:        C header files for pygame modules
62 Summary(pl.UTF-8):      Pliki nagłówkowe języka C modułów pygame
63 Group:          Development/Languages/Python
64 %pyrequires_eq  python
65 Requires:       %{name} = %{version}-%{release}
66 Obsoletes:      python-pygame-devel
67
68 %description devel
69 C header files for pygame modules.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe języka C modułów pygame.
73
74 %prep
75 %setup -q -n %{module}-%{version}-%{_alpha}
76
77 %build
78 CFLAGS="%{rpmcflags} -I/usr/include/smpeg"; export CFLAGS
79 %py_build
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %py_install
86
87 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88
89 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
90 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
91 %py_postclean
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc NEWS.txt PKG-INFO README.txt TODO.txt doc/*
99 %dir %{py_sitedir}/%{module}
100 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
101 %{py_sitedir}/%{module}/*.py[co]
102 %dir %{py_sitedir}/%{module}/threads/
103 %{py_sitedir}/%{module}/threads/*.py[co]
104
105 %files devel
106 %defattr(644,root,root,755)
107 %{py_incdir}/%{module}
108 %{_examplesdir}/%{name}-%{version}
This page took 0.196218 seconds and 3 git commands to generate.