]> git.pld-linux.org Git - SPECS.git/blob - python-pyevent.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / python-pyevent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  pyevent
6
7 Summary:        Python extension module for libevent
8 Summary(pl.UTF-8):      Moduł rozszerzenia Pythona dla biblioteki libevent
9 Name:           python-%{module}
10 Version:        0.3
11 Release:        13
12 License:        MIT
13 Group:          Libraries/Python
14 Source0:        http://pyevent.googlecode.com/files/%{module}-%{version}.tar.gz
15 # Source0-md5:  584912c92d08bf005283fb29a47a6e4d
16 Patch0:         %{name}-python25.patch
17 Patch1:         %{name}-setup.patch
18 Patch2:         libevent-2.1.patch
19 Patch3:         test-path.patch
20 URL:            http://code.google.com/p/pyevent/
21 BuildRequires:  rpmbuild(macros) >= 1.710
22 BuildRequires:  libevent-devel
23 BuildRequires:  python-Pyrex
24 BuildRequires:  python-devel >= 1:2.5
25 BuildRequires:  python-modules
26 BuildRequires:  rpm-pythonprov
27 %pyrequires_eq  python-libs
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Python extension module for libevent.
32
33 %description -l pl.UTF-8
34 Moduł rozszerzenia Pythona dla biblioteki libevent.
35
36 %prep
37 %setup -q -n %{module}-%{version}
38 %patch0 -p1
39 %patch1 -p1
40 %patch2 -p1
41 %patch3 -p1
42
43 %build
44 pyrexc event.pyx
45 %py_build
46 %{?with_tests:./test.py}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %py_install
52
53 %py_postclean
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES README
61 %attr(755,root,root) %{py_sitedir}/event.so
62 %{py_sitedir}/event-*.egg-info
This page took 0.564184 seconds and 3 git commands to generate.