]> git.pld-linux.org Git - packages/python-pydot.git/blob - python-pydot.spec
Version 1.0.28.
[packages/python-pydot.git] / python-pydot.spec
1 %define         module  pydot
2 Summary:        Python interface to Graphviz's Dot language
3 Summary(pl.UTF-8):      Pythonowy interfejs do języka Dot z pakietu Graphviz
4 Name:           python-%{module}
5 Version:        1.0.28
6 Release:        0.1
7 License:        MIT
8 Group:          Libraries/Python
9 Source0:        http://pydot.googlecode.com/files/pydot-%{version}.tar.gz
10 # Source0-md5:  c0a7a027176a62c412fd0f54951af692
11 URL:            http://code.google.com/p/pydot/
12 BuildRequires:  python-pyparsing >= 1.2
13 BuildRequires:  rpm-pythonprov
14 # if py_postclean is used
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 Requires:       python-modules
17 Requires:       python-pyparsing >= 1.2
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 pydot provides an interface for creating both directed and non
23 directed graphs from Python. Currently all attributes implemented in
24 the Dot language up to Graphviz 2.26.3 are supported.
25
26 %description -l pl.UTF-8
27 pydot udostępnia interfejs do tworzenia zarówno skierowanych jak i
28 nieskierowanych grafów z poziomu Pythona. Aktualnie obsługuje
29 wszystkie atrybuty zaimplementowane w języku dot do wersji Graphviza
30 2.26.3.
31
32 %prep
33 %setup -q -n %{module}-%{version}
34
35 %build
36 %{__python} setup.py build --build-base build-2
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
41 %{__python} setup.py \
42         build --build-base build-2 \
43         install --skip-build \
44         --optimize=2 \
45         --root=$RPM_BUILD_ROOT
46 %py_postclean
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 # %%doc ChangeLog LICENSE README
54 %{py_sitescriptdir}/*.py[co]
55 %if "%{py_ver}" > "2.4"
56 %{py_sitescriptdir}/pydot-*.egg-info
57 %endif
This page took 0.055442 seconds and 4 git commands to generate.