]> git.pld-linux.org Git - SPECS.git/blob - python-pyRXP.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-pyRXP.spec
1
2 #
3 # todo:
4 # - use external rxp
5 # - make documentation from rml file instead of downloading it
6 #   (need for spec for http://www.reportlab.org/rl_toolkit.html)
7 #
8
9 %define         _snap   20071106
10 %define         module  pyRXP
11
12 Summary:        A Python wrapper for the RXP parser
13 Summary(pl.UTF-8):      Pythonowy interfejs do analizatora XML RXP
14 Name:           python-%{module}
15 Version:        1.12
16 Release:        1
17 License:        GPL v2
18 Group:          Libraries/Python
19 Source0:        http://www.reportlab.org/daily/%{module}-%{version}-daily-unix.tgz
20 # Source0-md5:  614ec61a1f65231e8018897b5f5e2f5f
21 Source1:        http://www.reportlab.com/docs/PyRXP_Documentation.pdf
22 # Source1-md5:  984096b03131336f4eb53de829782576
23 URL:            http://www.reportlab.org/pyrxp.html
24 BuildRequires:  rpmbuild(macros) >= 1.710
25 BuildRequires:  python-devel >= 1:2.5
26 BuildRequires:  rpm-pythonprov
27 %pyrequires_eq  python-modules
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 pyRXP is a Python wrapper for RXP, a validating namespace-aware
32 XML parser in C.
33
34 %description -l pl.UTF-8
35 pyRXP to pythonowy interfejs do RXP - kontrolującego poprawność
36 analizatora XML-a z obsługą przestrzeni nazw, napisanego w C.
37
38 %package doc
39 Summary:        Documentation for Python pyRXP module
40 Summary(pl.UTF-8):      Dokumentacja do modułu Pythona pyRXP
41 Group:          Libraries/Python
42 Requires:       %{name} = %{version}-%{release}
43
44 %description doc
45 This package contains documentation files for Python pyRXP module.
46
47 %description doc -l pl.UTF-8
48 Pakiet zawierający dokumentację dla modułu Pythona pyRXP.
49
50 %package examples
51 Summary:        Example programs for Python pyRXP module
52 Summary(pl.UTF-8):      Programy przykładowe do modułu Pythona pyRXP
53 Group:          Development/Languages/Python
54 Requires:       %{name} = %{version}-%{release}
55
56 %description examples
57 This package contains example programs for Python pyRXP module.
58
59 %description examples -l pl.UTF-8
60 Pakiet zawierający programy przykładowe dla modułu Pythona pyRXP.
61
62 %prep
63 %setup -q -n pyRXP-%{version}-%{_snap}
64
65 %build
66 cd pyRXP
67 %py_build
68
69 cp -a %{SOURCE1} docs
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
74
75 cd pyRXP
76 %py_install
77
78 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc pyRXP/README
86 %{py_sitedir}/pyRXP-%{version}-py*.egg-info
87 %attr(755,root,root) %{py_sitedir}/*.so
88
89 %files doc
90 %defattr(644,root,root,755)
91 %doc pyRXP/docs/PyRXP_Documentation.pdf
92
93 %files examples
94 %defattr(644,root,root,755)
95 %{_examplesdir}/%{name}-%{version}
This page took 0.264725 seconds and 3 git commands to generate.