]> git.pld-linux.org Git - packages/python-psycopg2.git/blob - python-psycopg2.spec
- Version 1.1.6. Not tested.
[packages/python-psycopg2.git] / python-psycopg2.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         module psycopg
4
5 Summary:        psycopg is a PostgreSQL database adapter for Python
6 Summary(pl):    psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
7 Name:           python-%{module}
8 Version:        1.1.6
9 Release:        0.9
10 License:        GPL
11 Group:          Libraries/Python
12 Source0:        http://initd.org/pub/software/%{module}/%{module}-%{version}.tar.gz
13 # Source0-md5:  8a2b4f81a70cafc0da46b4c560801b37
14 Patch0:         %{name}-dumb-ac-fix.patch
15 URL:            http://www.initd.org/software/psycopg/
16 BuildRequires:  postgresql-backend-devel
17 BuildRequires:  python-devel
18 BuildRequires:  python-mx-DateTime-devel
19 Requires:       postgresql-libs
20 Requires:       python
21 Requires:       python-mx-DateTime
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 psycopg is a PostgreSQL database adapter for the Python programming
26 language (just like pygresql and popy.) It was written from scratch
27 with the aim of being very small and fast, and stable as a rock. The
28 main advantages of psycopg are that it supports the full Python
29 DBAPI-2.0 and being thread safe at level 2.
30
31 %description -l pl
32 psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
33 PostgreSQL (tak jak pygresql i popy). Zosta³ zakodowany od pocz±tku
34 z za³o¿eniem ¿e ma byæ bardzo ma³y, szybki i stabilny. G³ówna zalet±
35 psycopg jest, ¿e w jest pe³ni zgodny z standardem DBAPI-2.0 i jest
36 'thread safe' na poziomie 2.
37
38 %prep
39 %setup -q -n %{module}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__autoconf}
44
45 %configure \
46         --with-python=%{_bindir}/python \
47         --with-mxdatetime-includes=%{py_incdir}/mx \
48         --with-postgres-includes=%{_includedir}/postgresql/server
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{py_sitedir}
54
55 install psycopgmodule.so $RPM_BUILD_ROOT%{py_sitedir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS CREDITS FAQ NEWS README RELEASE-1.0 SUCCESS TODO doc
63 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.028103 seconds and 4 git commands to generate.