]> git.pld-linux.org Git - packages/python-psycopg2.git/blob - python-psycopg2.spec
- cleanups
[packages/python-psycopg2.git] / python-psycopg2.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         module psycopg
4
5 Summary:        psycopg is a PostgreSQL database adapter for Python
6 Summary(pl):    psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
7 Name:           python-%{module}
8 Version:        1.0.12
9 Release:        0.9
10 License:        GPL
11 Group:          Applications/Databases
12 Source0:        http://initd.org/pub/software/%{module}/%{module}-%{version}.tar.gz
13 Patch0:         %{name}-dumb-ac-fix.patch
14 URL:            http://www.initd.org/software/psycopg/
15 BuildRequires:  postgresql-backend-devel
16 BuildRequires:  python-devel
17 BuildRequires:  python-mx-DateTime-devel
18 Requires:       postgresql-libs
19 Requires:       python
20 Requires:       python-egenix-mx-base
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 psycopg is a PostgreSQL database adapter for the Python programming
25 language (just like pygresql and popy.) It was written from scratch
26 with the aim of being very small and fast, and stable as a rock. The
27 main advantages of psycopg are that it supports the full Python
28 DBAPI-2.0 and being thread safe at level 2.
29
30 %description -l pl
31 psycopg jest przeznaczonym dla Pythona interfejsem do bazy danych
32 PostgreSQL (tak jak pygresql i popy). Zosta³ zakodowany od pocz±tku
33 z za³o¿eniem ¿e ma byæ bardzo ma³y, szybki i stabilny. G³ówna zalet±
34 psycopg jest, ¿e w jest pe³ni zgodny z standardem DBAPI-2.0 i jest
35 'thread safe' na poziomie 2.
36
37 %prep
38 %setup -q -n %{module}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__autoconf}
43
44 %configure \
45         --with-python=%{_bindir}/python \
46         --with-mxdatetime-includes=%{py_sitedir}/mx/DateTime/mxDateTime  \
47         --with-postgres-includes=%{_includedir}/postgresql/server
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{py_sitedir}
53
54 install psycopgmodule.so $RPM_BUILD_ROOT%{py_sitedir}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS CREDITS FAQ NEWS README RELEASE-1.0 SUCCESS TODO doc
62 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.054896 seconds and 4 git commands to generate.