]> git.pld-linux.org Git - SPECS.git/blob - python-progressbar.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-progressbar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_with     python3 # CPython 3.x module
6
7 %define         module  progressbar
8 Summary:        Text progressbar library for python
9 Name:           python-%{module}
10 Version:        2.3
11 Release:        2
12 License:        LGPL
13 Group:          Libraries/Python
14 Source0:        https://python-progressbar.googlecode.com/files/progressbar-%{version}.tar.gz
15 # Source0-md5:  4f904e94b783b4c6e71aa74fd2432c59
16 URL:            https://code.google.com/p/python-progressbar/
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 BuildRequires:  python-distribute
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  sed >= 4.0
21 %if %{with python3}
22 BuildRequires:  python3-devel
23 BuildRequires:  python3-distribute
24 BuildRequires:  python3-modules
25 %endif
26 Requires:       python-modules
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This library provides a text mode progressbar. This is tipically used
32 to display the progress of a long running operation, providing a
33 visual clue that processing is underway.
34
35 %package -n python3-%{module}
36 Summary:        Text progressbar library for python
37 Group:          Libraries/Python
38
39 %description -n python3-%{module}
40 This library provides a text mode progressbar. This is tipically used
41 to display the progress of a long running operation, providing a
42 visual clue that processing is underway.
43
44 %prep
45 %setup -q -n %{module}-%{version}
46
47 %build
48 %if %{with python2}
49 %py_build %{?with_tests:test}
50 %endif
51
52 %if %{with python3}
53 %py3_build %{?with_tests:test}
54 %endif
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %if %{with python2}
60 %py_install
61
62 %py_postclean
63 %endif
64
65 %if %{with python3}
66 %py3_install
67 %endif
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with python2}
73 %files
74 %defattr(644,root,root,755)
75 %doc README.txt
76 %{py_sitescriptdir}/%{module}
77 %if "%{py_ver}" > "2.4"
78 %{py_sitescriptdir}/%{module}-*.egg-info
79 %endif
80 %endif
81
82 %if %{with python3}
83 %files -n python3-%{module}
84 %defattr(644,root,root,755)
85 %doc README.txt
86 %{py3_sitescriptdir}/%{module}
87 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
88 %endif
This page took 0.639869 seconds and 3 git commands to generate.