]> git.pld-linux.org Git - packages/python-pkgconfig.git/blob - python-pkgconfig.spec
- new
[packages/python-pkgconfig.git] / python-pkgconfig.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Python 2 interface to pkg-config
8 Summary(pl.UTF-8):      Interfejs Pythona 2 do narzędzia pkg-config
9 Name:           python-pkgconfig
10 Version:        1.2.2
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/pkgconfig
15 Source0:        https://files.pythonhosted.org/packages/source/p/pkgconfig/pkgconfig-%{version}.tar.gz
16 # Source0-md5:  81a8f6ef3371831d081e03db39e09683
17 URL:            http://github.com/matze/pkgconfig
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.6
20 BuildRequires:  python-nose >= 1.0
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.2
25 BuildRequires:  python3-nose >= 1.0
26 BuildRequires:  python3-setuptools
27 %endif
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  rpmbuild(macros) >= 1.714
30 Requires:       python-modules >= 1:2.6
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 pkgconfig is a Python module to interface with the pkg-config command
36 line tool.
37
38 %description -l pl.UTF-8
39 pkgconfig to moduł Pythona do współpracy z narzędziem linii poleceń
40 pkg-config.
41
42 %package -n python3-pkgconfig
43 Summary:        Python 3 interface to pkg-config
44 Summary(pl.UTF-8):      Interfejs Pythona 3 do narzędzia pkg-config
45 Group:          Libraries/Python
46 Requires:       python3-modules >= 1:3.2
47
48 %description -n python3-pkgconfig
49 pkgconfig is a Python module to interface with the pkg-config command
50 line tool.
51
52 %description -n python3-pkgconfig -l pl.UTF-8
53 pkgconfig to moduł Pythona do współpracy z narzędziem linii poleceń
54 pkg-config.
55
56 %prep
57 %setup -q -n pkgconfig-%{version}
58
59 %build
60 %if %{with python2}
61 %py_build
62
63 %{?with_tests:%{__python} -m nose test.py}
64 %endif
65
66 %if %{with python3}
67 %py3_build
68
69 %{?with_tests:%{__python3} -m nose test.py}
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python2}
76 %py_install
77
78 %py_postclean
79 %endif
80
81 %if %{with python3}
82 %py3_install
83 %endif
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %files
90 %defattr(644,root,root,755)
91 %doc LICENSE README.rst
92 %{py_sitescriptdir}/pkgconfig
93 %{py_sitescriptdir}/pkgconfig-%{version}-py*.egg-info
94 %endif
95
96 %if %{with python3}
97 %files -n python3-pkgconfig
98 %defattr(644,root,root,755)
99 %doc LICENSE README.rst
100 %{py3_sitescriptdir}/pkgconfig
101 %{py3_sitescriptdir}/pkgconfig-%{version}-py*.egg-info
102 %endif
This page took 0.37268 seconds and 3 git commands to generate.