]> git.pld-linux.org Git - packages/python-netaddr.git/blob - python-netaddr.spec
- release 2
[packages/python-netaddr.git] / python-netaddr.spec
1 %define         module  netaddr
2 Summary:        A pure Python network address representation and manipulation library
3 Name:           python-netaddr
4 Version:        0.7.3
5 Release:        2
6 License:        BSD
7 Group:          Development/Languages/Python
8 Source0:        http://netaddr.googlecode.com/files/netaddr-%{version}.tar.gz
9 # Source0-md5:  8b7b574bca2f60722ccd90c71334ee32
10 URL:            http://code.google.com/p/netaddr/
11 BuildRequires:  python-devel
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 A pure Python network address representation and manipulation library.
17
18 netaddr provides a Pythonic way to work with:
19 - IPv4 and IPv6 addresses and subnets (including CIDR notation)
20 - MAC (Media Access Control) addresses in multiple presentation
21   formats
22 - IEEE EUI-64, OUI and IAB identifiers
23 - nmap-style IP address ranges
24 - a user friendly IP glob-style format
25
26 Included are routines for:
27 - generating, sorting and summarizing IP addresses
28 - converting IP addresses and ranges between various different formats
29 - performing set based operations on groups of IP addresses and
30   subnets
31 - arbitrary IP address range calculations and conversions
32 - querying IEEE OUI and IAB organisational information
33 - querying of IP standards related data from key IANA data sources
34
35 %prep
36 %setup -q -n %{module}-%{version}
37
38 %build
39 %{__python} ./setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__python} ./setup.py install \
45         --optimize 2 \
46         --root=$RPM_BUILD_ROOT
47
48 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
49 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc docs/api AUTHORS CHANGELOG README THANKS
58 %attr(755,root,root) %{_bindir}/netaddr
59 %{py_sitescriptdir}/*.egg-info
60 %dir %{py_sitescriptdir}/%{module}
61 %{py_sitescriptdir}/%{module}/*.py[co]
62 %dir %{py_sitescriptdir}/%{module}/eui
63 %{py_sitescriptdir}/%{module}/eui/*.py[co]
64 %{py_sitescriptdir}/%{module}/eui/*.idx
65 %{py_sitescriptdir}/%{module}/eui/*.txt
66 %dir %{py_sitescriptdir}/%{module}/ip
67 %{py_sitescriptdir}/%{module}/ip/*.py[co]
68 %{py_sitescriptdir}/%{module}/ip/*-space
69 %{py_sitescriptdir}/%{module}/ip/*-addresses
70 %dir %{py_sitescriptdir}/%{module}/strategy
71 %{py_sitescriptdir}/%{module}/strategy/*.py[co]
72 %dir %{py_sitescriptdir}/%{module}/tests
73 %{py_sitescriptdir}/%{module}/tests/*.py[co]
74 %{py_sitescriptdir}/%{module}/tests/core
75 %{py_sitescriptdir}/%{module}/tests/eui
76 %{py_sitescriptdir}/%{module}/tests/ip
77 %{py_sitescriptdir}/%{module}/tests/strategy
This page took 0.036036 seconds and 4 git commands to generate.