]> git.pld-linux.org Git - packages/python-netaddr.git/blob - python-netaddr.spec
- up to 0.7.4
[packages/python-netaddr.git] / python-netaddr.spec
1 %define         module  netaddr
2 Summary:        A pure Python network address representation and manipulation library
3 Name:           python-netaddr
4 Version:        0.7.4
5 Release:        1
6 License:        BSD
7 Group:          Development/Languages/Python
8 Source0:        http://netaddr.googlecode.com/files/netaddr-%{version}.tar.gz
9 # Source0-md5:  8b7b574bca2f60722ccd90c71334ee32
10 URL:            http://code.google.com/p/netaddr/
11 BuildRequires:  python-devel
12 BuildRequires:  python-modules
13 BuildRequires:  rpm-pythonprov
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 A pure Python network address representation and manipulation library.
19
20 netaddr provides a Pythonic way to work with:
21 - IPv4 and IPv6 addresses and subnets (including CIDR notation)
22 - MAC (Media Access Control) addresses in multiple presentation
23   formats
24 - IEEE EUI-64, OUI and IAB identifiers
25 - nmap-style IP address ranges
26 - a user friendly IP glob-style format
27
28 Included are routines for:
29 - generating, sorting and summarizing IP addresses
30 - converting IP addresses and ranges between various different formats
31 - performing set based operations on groups of IP addresses and
32   subnets
33 - arbitrary IP address range calculations and conversions
34 - querying IEEE OUI and IAB organisational information
35 - querying of IP standards related data from key IANA data sources
36
37 %prep
38 %setup -q -n %{module}-%{version}
39
40 %build
41 %{__python} ./setup.py build
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__python} ./setup.py install \
47         --optimize 2 \
48         --root=$RPM_BUILD_ROOT
49
50 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
51 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
52 %py_postclean
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc docs/api AUTHORS CHANGELOG README THANKS
60 %attr(755,root,root) %{_bindir}/netaddr
61 %{py_sitescriptdir}/*.egg-info
62 %dir %{py_sitescriptdir}/%{module}
63 %{py_sitescriptdir}/%{module}/*.py[co]
64 %dir %{py_sitescriptdir}/%{module}/eui
65 %{py_sitescriptdir}/%{module}/eui/*.py[co]
66 %{py_sitescriptdir}/%{module}/eui/*.idx
67 %{py_sitescriptdir}/%{module}/eui/*.txt
68 %dir %{py_sitescriptdir}/%{module}/ip
69 %{py_sitescriptdir}/%{module}/ip/*.py[co]
70 %{py_sitescriptdir}/%{module}/ip/*-space
71 %{py_sitescriptdir}/%{module}/ip/*-addresses
72 %dir %{py_sitescriptdir}/%{module}/strategy
73 %{py_sitescriptdir}/%{module}/strategy/*.py[co]
74 %dir %{py_sitescriptdir}/%{module}/tests
75 %{py_sitescriptdir}/%{module}/tests/*.py[co]
76 %{py_sitescriptdir}/%{module}/tests/core
77 %{py_sitescriptdir}/%{module}/tests/eui
78 %{py_sitescriptdir}/%{module}/tests/ip
79 %{py_sitescriptdir}/%{module}/tests/strategy
This page took 0.057037 seconds and 4 git commands to generate.