]> git.pld-linux.org Git - SPECS.git/blob - python-modulegraph.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python-modulegraph.spec
1 # %bcond_without        tests   # do not perform "make test"
2
3 %define         module  modulegraph
4 Summary:        Module dependency analysis tool
5 Name:           python-%{module}
6 Version:        0.10.2
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/Python
10 Source0:        http://pypi.python.org/packages/source/m/modulegraph/modulegraph-%{version}.tar.gz
11 # Source0-md5:  83c74c264843b83c92f62ed9856e49a8
12 URL:            http://pypi.python.org/pypi/modulegraph
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 # if py_postclean is used
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 Requires:       python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 modulegraph determines a dependency graph between Python modules
22 primarily by bytecode analysis for import statements.
23
24 modulegraph uses similar methods to modulefinder from the standard
25 library, but uses a more flexible internal representation, has more
26 extensive knowledge of special cases, and is extensible.
27
28 %prep
29 %setup -q -n modulegraph-%{version}
30
31 %build
32 %py_build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 %py_install
38
39 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
40 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
41 %py_postclean
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README.txt
49 %attr(755,root,root) %{_bindir}/modulegraph
50 %dir %{py_sitescriptdir}/%{module}
51 %{py_sitescriptdir}/%{module}/*.py[co]
52 %if "%{py_ver}" > "2.4"
53 %{py_sitescriptdir}/%{module}*.egg-info
54 %endif
This page took 0.09347 seconds and 3 git commands to generate.