]> git.pld-linux.org Git - SPECS.git/blob - python-jabber.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-jabber.spec
1
2 %define         module  jabber
3
4 Summary:        "jabber.py" Python module for Jabber applications
5 Summary(pl.UTF-8):      Moduły Pythona "jabber.py" dla aplikacji Jabber
6 Name:           python-%{module}
7 Version:        0.5
8 Release:        5
9 License:        GPL
10 Group:          Libraries/Python
11 Source0:        http://downloads.sourceforge.net/jabberpy/jabberpy-%{version}-0.tar.gz
12 # Source0-md5:  cbb9a1126bdc39ff49af605fb55c282e
13 URL:            http://jabberpy.sourceforge.net/
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 jabber.py is a Python module for the Jabber instant messaging
24 protocol. jabber.py deals with the XML parsing and socket code,
25 leaving the programmer to concentrate on developing quality Jabber
26 based applications with Python.
27
28 %description -l pl.UTF-8
29 jabber.py to moduł Pythona do protokołu komunikatora Jabber. jabber.py
30 obsługuje analizowanie XML-a i gniazda, pozwalając programiście
31 skoncentrować się na tworzeniu w Pythonie wysokiej jakości aplikacji
32 opartych na Jabberze.
33
34 %prep
35 %setup -q -n jabberpy-%{version}-0
36
37 %build
38 # next version can contain __init__.py, so check if this workaround is
39 # still required, please
40 # see also:
41 # http://sourceforge.net/tracker/index.php?func=detail&aid=897527&group_id=30215&atid=398567
42 echo 'from jabber import *' > jabber/__init__.py
43 %py_build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 %py_install
50
51 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/jabber/*.py
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CREDITS README
61 %{py_sitescriptdir}/jabber
62 %dir %{_examplesdir}/%{name}-%{version}
63 %{_examplesdir}/%{name}-%{version}/*
This page took 0.450164 seconds and 3 git commands to generate.