]> git.pld-linux.org Git - packages/python-iso8601.git/blob - python-iso8601.spec
automatic change: use py_build/py_install macros
[packages/python-iso8601.git] / python-iso8601.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  iso8601
6 Summary:        Simple module to parse ISO 8601 dates
7 Name:           python-%{module}
8 Version:        0.1.8
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://pypi.python.org/packages/source/i/iso8601/%{module}-%{version}.tar.gz
13 # Source0-md5:  b207ad4f2df92810533ce6145ab9c3e7
14 URL:            https://bitbucket.org/micktwomey/pyiso8601
15 BuildRequires:  python-devel
16 BuildRequires:  python-setuptools
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module parses the most common forms of ISO 8601 date strings
23 (e.g. 2007-01-14T20:34:22+00:00) into datetime objects.
24
25 %prep
26 %setup -qn %{module}-%{version}
27
28 %build
29 %py_build
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 %py_install
34
35 %py_postclean
36
37 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/iso8601/test_*
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc README.rst LICENSE
45 %{py_sitescriptdir}/iso8601
46 %{py_sitescriptdir}/iso8601-%{version}-py*.egg-info
This page took 0.0919 seconds and 4 git commands to generate.