]> git.pld-linux.org Git - SPECS.git/blob - python-incremental.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / python-incremental.spec
1 # TODO: apidocs (BR: pydoctor), tests (BR: twisted.trial >= 16.4.0, click >= 6.0)
2 #
3 # Conditional build:
4 %bcond_with     doc     # API documentation (pydoctor based)
5 %bcond_with     tests   # unit tests (require Twisted)
6 %bcond_without  python2 # CPython 2.x module
7 %bcond_without  python3 # CPython 3.x module
8
9 Summary:        Library that versions Python projects
10 Summary(pl.UTF-8):      Biblioteka wersjonująca projekty w Pythonie
11 Name:           python-incremental
12 Version:        22.10.0
13 Release:        1
14 License:        MIT
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/incremental/
17 Source0:        https://files.pythonhosted.org/packages/source/i/incremental/incremental-%{version}.tar.gz
18 # Source0-md5:  9fffa2490ca649550c79a78e85ef2eef
19 URL:            https://pypi.org/project/incremental/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-click >= 6.0
25 BuildRequires:  python-twisted >= 16.4.0
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules >= 1:3.4
30 BuildRequires:  python3-setuptools
31 %if %{with tests}
32 BuildRequires:  python3-click >= 6.0
33 BuildRequires:  python3-twisted >= 16.4.0
34 %endif
35 %endif
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.714
38 %if %{with doc}
39 BuildRequires:  pydoctor
40 %endif
41 Requires:       python-modules >= 1:2.7
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Incremental is a small library that versions your Python projects.
47
48 %description -l pl.UTF-8
49 Incremental to mała biblioteka do wersjonowania projektów w Pythonie.
50
51 %package -n python3-incremental
52 Summary:        Library that versions Python projects
53 Summary(pl.UTF-8):      Biblioteka wersjonująca projekty w Pythonie
54 Group:          Libraries/Python
55 Requires:       python3-modules >= 1:3.4
56
57 %description -n python3-incremental
58 Incremental is a small library that versions your Python projects.
59
60 %description -n python3-incremental -l pl.UTF-8
61 Incremental to mała biblioteka do wersjonowania projektów w Pythonie.
62
63 %package apidocs
64 Summary:        API documentation for Python incremental module
65 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona incremental
66 Group:          Documentation
67
68 %description apidocs
69 API documentation for Python incremental module.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API modułu Pythona incremental.
73
74 %prep
75 %setup -q -n incremental-%{version}
76
77 %build
78 %if %{with python2}
79 %py_build
80
81 %if %{with tests}
82 trial-2 incremental
83 %endif
84 %endif
85
86 %if %{with python3}
87 %py3_build
88
89 %if %{with tests}
90 trial-3 incremental
91 %endif
92 %endif
93
94 %if %{with doc}
95 pydoctor -q --project-name incremental src/incremental
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %py_install
103
104 %py_postclean
105 %endif
106
107 %if %{with python3}
108 %py3_install
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %files
116 %defattr(644,root,root,755)
117 %doc LICENSE NEWS.rst README.rst
118 %{py_sitescriptdir}/incremental
119 %{py_sitescriptdir}/incremental-%{version}-py*.egg-info
120 %endif
121
122 %if %{with python3}
123 %files -n python3-incremental
124 %defattr(644,root,root,755)
125 %doc LICENSE NEWS.rst README.rst
126 %{py3_sitescriptdir}/incremental
127 %{py3_sitescriptdir}/incremental-%{version}-py*.egg-info
128 %endif
129
130 %if %{with doc}
131 %files apidocs
132 %defattr(644,root,root,755)
133 %doc # TODO
134 %endif
This page took 1.03419 seconds and 3 git commands to generate.