]> git.pld-linux.org Git - SPECS.git/blob - python-httpbin.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-httpbin.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  template
7 Summary:        HTTP Request and Response Service
8 Summary(pl.UTF-8):      Usługa żądań i odpowiedzi HTTP
9 Name:           python-httpbin
10 Version:        0.5.0
11 Release:        3
12 License:        ISC
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/httpbin
15 Source0:        https://files.pythonhosted.org/packages/source/h/httpbin/httpbin-%{version}.tar.gz
16 # Source0-md5:  923793df99156caa484975ade96ee115
17 URL:            https://github.com/Runscope/httpbin
18 %if %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
19 BuildRequires:  glibc-localedb-all
20 %endif
21 %if %{with python2}
22 BuildRequires:  python-modules >= 1:2.7
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.4
27 BuildRequires:  python3-setuptools
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 Requires:       python-modules >= 1:2.7
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 HTTP Request and Response Service.
37
38 %description -l pl.UTF-8
39 Usługa żądań i odpowiedzi HTTP.
40
41 %package -n python3-httpbin
42 Summary:        HTTP Request and Response Service
43 Summary(pl.UTF-8):      Usługa żądań i odpowiedzi HTTP
44 Group:          Libraries/Python
45 Requires:       python3-modules >= 1:3.4
46
47 %description -n python3-httpbin
48 HTTP Request and Response Service.
49
50 %description -n python3-httpbin -l pl.UTF-8
51 Usługa żądań i odpowiedzi HTTP.
52
53 %prep
54 %setup -q -n httpbin-%{version}
55
56 %build
57 %if %{with python2}
58 %py_build
59 %endif
60
61 %if %{with python3}
62 LC_ALL=C.UTF-8 %py3_build
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %if %{with python2}
69 %py_install
70
71 %py_postclean
72 %endif
73
74 %if %{with python3}
75 LC_ALL=C.UTF-8 %py3_install
76 %endif
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS LICENSE README.rst
85 %{py_sitescriptdir}/httpbin
86 %{py_sitescriptdir}/httpbin-%{version}-py*.egg-info
87 %endif
88
89 %if %{with python3}
90 %files -n python3-httpbin
91 %defattr(644,root,root,755)
92 %doc AUTHORS LICENSE README.rst
93 %{py3_sitescriptdir}/httpbin
94 %{py3_sitescriptdir}/httpbin-%{version}-py*.egg-info
95 %endif
This page took 0.422702 seconds and 3 git commands to generate.