]> git.pld-linux.org Git - packages/python-fuse.git/blob - python-fuse.spec
- initial
[packages/python-fuse.git] / python-fuse.spec
1 %define         module  fuse
2
3 Summary:        Python interface to FUSE (Filesystem in USErspace)
4 Name:           python-%{module}
5 Version:        0.1
6 Release:        0.1
7 License:        GPL
8 Group:          Development/Languages/Python
9 Source0:        http://richard.jones.name/google-hacks/gmail-filesystem/%{module}-python.tar.gz
10 # Source0-md5:  932cd7f1997187245206385515865ffd
11 # Source0-size: 14064
12 URL:            http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html
13 BuildRequires:  python-devel
14 BuildRequires:  libfuse-devel
15 %pyrequires_eq  python-modules
16 Requires:       libfuse
17 Requires:       fusermount
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Python interface to FUSE (Filesystem in USErspace).
23
24 %prep
25 %setup -q -n %{module}-python
26
27 %build
28 %{py_comp} .
29 %{py_ocomp} .
30 %{__make}
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{py_sitedir}}
36 install fuse.py[co] $RPM_BUILD_ROOT%{py_sitescriptdir}
37 install _fusemodule.so $RPM_BUILD_ROOT%{py_sitedir}/_fusemodule.so
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc README
45 %{py_sitescriptdir}/*.py[co]
46 %{py_sitedir}/_fusemodule.so
This page took 0.059659 seconds and 4 git commands to generate.