]> git.pld-linux.org Git - SPECS.git/blob - python-fastimport.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python-fastimport.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4
5 %define         module  fastimport
6 Summary:        Python parser for fastimport (VCS interchange format)
7 Summary(pl.UTF-8):      Pythonowy parser formatu fastimport (do wymiany VCS)
8 Name:           python-%{module}
9 # keep 0.9.8 here for python2 support
10 Version:        0.9.8
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/project/simple/
15 Source0:        https://files.pythonhosted.org/packages/source/f/fastimport/%{module}-%{version}.tar.gz
16 # Source0-md5:  85a206e92e209937a8dd11ffe8139cf9
17 URL:            https://pypi.org/project/fastimport/
18 BuildRequires:  python-modules >= 1:2.7
19 %if %{with tests}
20 BuildRequires:  python-nose
21 %endif
22 BuildRequires:  rpmbuild(macros) >= 1.714
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is the Python parser that was originally developed for
28 bzr-fastimport, but extracted so it can be used by other projects.
29
30 %description -l pl.UTF-8
31 Pythonowy parser, oryginalnie stworzony na potrzeby bzr-fastimport,
32 ale wyciągnięty do osobnego modułu, dzięki czemu może być używany
33 przez inne projekty.
34
35 %prep
36 %setup -q -n %{module}-%{version}
37
38 %build
39 %py_build
40
41 %if %{with tests}
42 nosetests-%{py_ver} fastimport
43 %endif
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %py_install
49
50 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
51 %py_postclean
52
53 for f in $RPM_BUILD_ROOT%{_bindir}/fast-import-* ; do
54         %{__mv} "$f" "${f}-2"
55 done
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS NEWS README.md
63 %attr(755,root,root) %{_bindir}/fast-import-filter-2
64 %attr(755,root,root) %{_bindir}/fast-import-info-2
65 %attr(755,root,root) %{_bindir}/fast-import-query-2
66 %{py_sitescriptdir}/fastimport
67 %{py_sitescriptdir}/fastimport-%{version}-py*.egg-info
This page took 1.211256 seconds and 3 git commands to generate.