]> git.pld-linux.org Git - SPECS.git/blob - python-elementary.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-elementary.spec
1 # NOTE: for EFL >= 1.8.0 version see python-efl.spec
2 Summary:        Python bindings for Elementary library
3 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary
4 Name:           python-elementary
5 Version:        1.7.0
6 Release:        15
7 License:        LGPL v3+
8 Group:          Development/Languages/Python
9 Source0:        http://download.enlightenment.org/releases/BINDINGS/python/%{name}-%{version}.tar.bz2
10 # Source0-md5:  38c8b2ac508ab4e1d12f1557a12169c9
11 URL:            http://trac.enlightenment.org/e/wiki/Python
12 BuildRequires:  elementary-devel >= 1.7.0
13 BuildRequires:  eina-devel >= 1.7.0
14 BuildRequires:  epydoc
15 BuildRequires:  evas-devel >= 1.7.0
16 BuildRequires:  python-Cython >= 0.15.1
17 BuildRequires:  python-devel >= 1:2.7
18 BuildRequires:  python-evas >= 1.7.0
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  pkgconfig >= 1:0.22
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 Requires:       elementary-libs >= 1.7.0
23 Requires:       eina >= 1.7.0
24 Requires:       evas >= 1.7.0
25 Requires:       python-evas >= 1.7.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Python bindings for Elementary library.
30
31 %description -l pl.UTF-8
32 Wiązania Pythona do biblioteki Elementary.
33
34 %package devel
35 Summary:        Python bindings for Elementary library - development files
36 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary - pliki programistyczne
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       elementary-devel >= 1.7.0
40 Requires:       eina-devel >= 1.7.0
41 Requires:       evas-devel >= 1.7.0
42 Requires:       python-evas-devel >= 1.7.0
43
44 %description devel
45 Python bindings for Elementary library - development files.
46
47 %description devel -l pl.UTF-8
48 Wiązania Pythona do biblioteki Elementary - pliki programistyczne.
49
50 %prep
51 %setup -q
52
53 %build
54 %configure \
55         --disable-silent-rules
56
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %py_postclean
66 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/elementary/c_elementary.la
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}
69 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc AUTHORS ChangeLog README
77 %dir %{py_sitedir}/elementary
78 %attr(755,root,root) %{py_sitedir}/elementary/c_elementary.so
79 %{py_sitedir}/elementary/*.py[co]
80 %{_examplesdir}/%{name}-%{version}
81
82 %files devel
83 %defattr(644,root,root,755)
84 %{_pkgconfigdir}/python-elementary.pc
This page took 0.393187 seconds and 3 git commands to generate.