]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blob - python-egenix-mx-base.spec
- split into subpackages, nfy
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
1
2 %define module egenix-mx-base
3 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
4 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
5 %define python_compile python -c "import compileall; compileall.compile_dir('.')"
6
7 Summary:        eGenix mx-Extensions for Python - BASE package
8 Name:           python-%{module}
9 Version:        2.0.1
10 Release:        1
11 URL:            http://www.lemburg.com/python/mxExtensions.html
12 Group:          Development/Languages/Python
13 Group(de):      Entwicklung/Sprachen/Python
14 Group(pl):      Programowanie/Jêzyki/Python
15 License:        Distributable
16 Source0:        http://www.lemburg.com/python/%{module}-%{version}.tar.gz
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The eGenix mx Extension Series are a collection of Python extensions
21 written in ANSI C and Python which provide a large spectrum of useful
22 additions to everyday Python programming.
23
24 The BASE package includes the Open Source subpackages of the series
25 and is needed by all other add-on packages of the series.
26
27 This software is brought to you by eGenix.com and distributed under
28 the eGenix.com Public License.
29
30 %package -n python-mx-DateTime
31 Summary:        Date and time Python extension
32 Summary(pl):    Obiekty daty i czasu dla jêzyka Python
33 Group:          Development/Languages/Python
34 Group(de):      Entwicklung/Sprachen/Python
35 Group(pl):      Programowanie/Jêzyki/Python
36 Requires:       python-%{module} = %{version}
37
38 %description -n python-mx-DateTime
39 mxDateTime is an extension package that provides three new object
40 types, DateTime, DateTimeDelta and RelativeDateTime, which let you
41 store and handle date/time values in a much more natural way than by
42 using ticks (seconds since 1.1.70 0:00 UTC; the encoding used by the
43 time module).
44
45 You can add, subtract and even multiply instances, pickle and copy
46 them and convert the results to strings, COM dates, ticks and some
47 other more esoteric values. In addition, there are several convenient
48 constructors and formatters at hand to greatly simplify dealing with
49 dates and times in real-world applications.
50
51 In addition to providing an easy-to-use Python interface the package
52 also exports a comfortable C API interface for other extensions to
53 build upon. This is especially interesting for database applications
54 which often have to deal with date/time values (the mxODBC package is
55 one example of an extension using this interface).
56
57 %description -l pl -n python-mx-DateTime
58 N/A
59
60 %package -n python-mx-TextTools
61 Summary:        Efficient text manipulation extensions for Python
62 Summary(pl):    Wydajne manipulowanie tekstem w jêzyku Python
63 Group:          Development/Languages/Python
64 Group(de):      Entwicklung/Sprachen/Python
65 Group(pl):      Programowanie/Jêzyki/Python
66 Requires:       python-%{module} = %{version}
67
68 %description -n python-mx-TextTools
69 mxTextTools is an extension package for Python that provides several
70 useful functions and types that implement high-performance text
71 manipulation and searching algorithms in addition to a very flexible
72 and extendable state machine, the Tagging Engine, that allows scanning
73 and processing text based on low-level byte-code "programs" written
74 using Python tuples. It gives you access to the speed of C without the
75 need to do any compile and link steps every time you change the
76 parsing description.
77
78 Applications include parsing structured text, finding and extracting
79 text (either exact or using translation tables) and recombining
80 strings to form new text.
81
82 %description -l pl -n python-mx-TextTools
83 N/A
84
85 %package -n python-mx-Stack
86 Summary:        Stack implementation for Python
87 Summary(pl):    Implementacja stosu dla jêzyka Python
88 Group:          Development/Languages/Python
89 Group(de):      Entwicklung/Sprachen/Python
90 Group(pl):      Programowanie/Jêzyki/Python
91 Requires:       python-%{module} = %{version}
92
93 %description -n python-mx-Stack
94 mxStack is an extension package that provides a new object type called
95 Stack. It works much like what you would expect from such a type,
96 having .push() and .pop() methods and focusses on obtaining maximum
97 speed at low memory costs.
98
99 %description -l pl -n python-mx-Stack
100 N/A
101
102 %package -n python-mx-Tools
103 Summary:        Some handy functions and objects which provides new builtins for Python
104 Group:          Development/Languages/Python
105 Group(de):      Entwicklung/Sprachen/Python
106 Group(pl):      Programowanie/Jêzyki/Python
107 Requires:       python-%{module} = %{version}
108
109 %description -n python-mx-Tools
110 mxTools is an extension package that includes a collection of handy
111 functions and objects giving additional functionality in form of new
112 builtins to the Python programmer.
113
114 The package auto-installs the new functions and objects as builtins
115 upon first import. This means that they become instantely available to
116 all other modules without any further action on your part. Add the
117 line import mx.Tools.NewBuiltins to your site.py script and they will
118 be available to all users at your site as if they were installed in
119 the Python interpreter itself.
120
121 %description -l pl -n python-mx-Tools
122 N/A
123
124 %package -n python-mx-Proxy
125 Summary:        Support for Bastion like implementations for Python
126 Group:          Development/Languages/Python
127 Group(de):      Entwicklung/Sprachen/Python
128 Group(pl):      Programowanie/Jêzyki/Python
129 Requires:       python-%{module} = %{version}
130
131 %description -n python-mx-Proxy
132 mxProxy is an extension package that provides a new type that is
133 suitable to implement Bastion like features without the need to use
134 restricted execution environments.
135
136 The type's main features are secure data encapsulation (the hidden
137 objects are not accessible from Python since they are stored in
138 internal C structures), customizable attribute lookup methods and a
139 cleanup protocol that helps in breaking circular references prior to
140 object deletion.
141
142 The latest version adds a very interesting new feature: weak
143 references which help you work with circular references in a way that
144 doesn't cause memory leakage in a Python system.
145
146 %description -l pl -n python-mx-Proxy
147 N/A
148
149 %package -n python-mx-BeeBase
150 Summary:        High performance construction kit for disk based indexed databases (B+Tree)
151 Group:          Development/Languages/Python
152 Group(de):      Entwicklung/Sprachen/Python
153 Group(pl):      Programowanie/Jêzyki/Python
154 Requires:       python-%{module} = %{version}
155
156 %description -n python-mx-BeeBase
157 mxBeeBase is a high performance construction kit for disk based
158 indexed databases. It offers components which you can plug together to
159 easily build your own custom mid-sized databases (the current size
160 limit is sizeof(long) which gives you an address range of around 2GB
161 on 32-bit platforms).
162
163 The two basic building blocks in mxBeeBase are storage and index.
164 Storage is implemented as variable record length data storage with
165 integrated data protection features, automatic data recovery and
166 locking for multi process access. Indexes use a high performance
167 optimized B+Tree implementation built on top of Thomas Niemann's
168 Cookbook B+Tree implementation.
169
170 %description -l pl -n python-mx-BeeBase
171 N/A
172
173 %prep
174 %setup -q -n %{module}-%{version}
175
176 %build
177 env CFLAGS="%{rpmcflags}" python setup.py build
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181 python setup.py install --root=$RPM_BUILD_ROOT
182
183 gzip -9nf README
184
185 %clean
186 rm -rf $RPM_BUILD_ROOT
187
188 %files
189 %defattr(644,root,root,755)
190 %doc README mx/Doc mx/DateTime/Doc mx/Proxy/Doc mx/BeeBase/Doc mx/Queue/Doc mx/Stack/Doc mx/TextTools/Doc mx/Tools/Doc mx/DateTime/LICENSE mx/DateTime/COPYRIGHT
191
192 %files -n python-mx-DateTime
193 %defattr(644,root,root,755)
194
195 %files -n python-mx-TextTools
196 %defattr(644,root,root,755)
197
198 %files -n python-mx-Stack
199 %defattr(644,root,root,755)
200
201 %files -n python-mx-Tools
202 %defattr(644,root,root,755)
203
204 %files -n python-mx-Proxy
205 %defattr(644,root,root,755)
206
207 %files -n python-mx-BeeBase
208 %defattr(644,root,root,755)
This page took 0.078889 seconds and 4 git commands to generate.