]> git.pld-linux.org Git - SPECS.git/blob - python-docwriter.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-docwriter.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        API reference documentation generator for FreeType
8 Summary(pl.UTF-8):      Generator dokumentacji referencyjnej API do biblioteki FreeType
9 Name:           python-docwriter
10 Version:        1.1.1
11 Release:        4
12 License:        FreeType
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/docwriter/
15 Source0:        https://files.pythonhosted.org/packages/source/d/docwriter/docwriter-%{version}.tar.gz
16 # Source0-md5:  b02be7127b31966f761af9798168155f
17 Patch0:         %{name}-requirements.patch
18 URL:            https://github.com/freetype/docwriter
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 BuildRequires:  python-setuptools_scm
23 %if %{with tests}
24 BuildRequires:  python-PyYAML >= 5.1
25 BuildRequires:  python-mistune >= 0.8.4
26 BuildRequires:  python-mkdocs >= 1.0.4
27 BuildRequires:  python-mkdocs-material >= 4.0.2
28 BuildRequires:  python-pytest
29 %endif
30 %endif
31 %if %{with python3}
32 BuildRequires:  python3-modules >= 1:3.4
33 BuildRequires:  python3-setuptools
34 BuildRequires:  python3-setuptools_scm
35 %if %{with tests}
36 BuildRequires:  python3-PyYAML >= 5.1
37 BuildRequires:  python3-mistune >= 0.8.4
38 BuildRequires:  python3-mkdocs >= 1.0.4
39 BuildRequires:  python3-mkdocs-material >= 4.0.2
40 BuildRequires:  python3-pytest
41 %endif
42 %endif
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.714
45 Requires:       python-modules >= 1:2.7
46 BuildArch:      noarch
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Docwriter is an API documentation generator for the FreeType Library
51 that extracts and builds Markdown docs from the FreeType header files.
52
53 %description -l pl.UTF-8
54 Docwriter to generator dokumentacji API dla biblioteki FreeType,
55 wydobywający i tworzący dokumentację Markdown z plików nagłówkowych
56 FreeType.
57
58 %package -n python3-docwriter
59 Summary:        API reference documentation generator for FreeType
60 Summary(pl.UTF-8):      Generator dokumentacji referencyjnej API do biblioteki FreeType
61 Group:          Libraries/Python
62 Requires:       python3-modules >= 1:3.4
63
64 %description -n python3-docwriter
65 Docwriter is an API documentation generator for the FreeType Library
66 that extracts and builds Markdown docs from the FreeType header files.
67
68 %description -n python3-docwriter -l pl.UTF-8
69 Docwriter to generator dokumentacji API dla biblioteki FreeType,
70 wydobywający i tworzący dokumentację Markdown z plików nagłówkowych
71 FreeType.
72
73 %prep
74 %setup -q -n docwriter-%{version}
75 %patch0 -p1
76
77 %build
78 %if %{with python2}
79 %py_build %{?with_tests:test}
80 %endif
81
82 %if %{with python3}
83 %py3_build %{?with_tests:test}
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with python2}
90 %py_install
91
92 %py_postclean
93 %endif
94
95 %if %{with python3}
96 %py3_install
97 %endif
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %if %{with python2}
103 %files
104 %defattr(644,root,root,755)
105 %doc README.md
106 %{py_sitescriptdir}/docwriter
107 %{py_sitescriptdir}/docwriter-%{version}-py*.egg-info
108 %endif
109
110 %if %{with python3}
111 %files -n python3-docwriter
112 %defattr(644,root,root,755)
113 %doc README.md
114 %{py3_sitescriptdir}/docwriter
115 %{py3_sitescriptdir}/docwriter-%{version}-py*.egg-info
116 %endif
This page took 1.305528 seconds and 3 git commands to generate.