]> git.pld-linux.org Git - SPECS.git/blob - python-django-registration.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-django-registration.spec
1 %define         module  django-registration
2 Summary:        Simple, portable, generic user-registration application for Django projects
3 Summary(pl.UTF-8):      Prosta i przenośna aplikacja do rejestrowania użytkowników w projektach Django
4 Name:           python-%{module}
5 Version:        0.8
6 Release:        3
7 License:        BSD
8 Group:          Development/Languages/Python
9 Source0:        http://pypi.python.org/packages/source/d/%{module}/%{module}-%{version}.tar.gz
10 # Source0-md5:  d3e785858e0040a6c3201acd43409b2e
11 URL:            https://bitbucket.org/ubernostrum/django-registration/
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.710
14 Requires:       python-django >= 1.3
15 Requires:       python-modules
16 Provides:       python-django_registration = %{version}-%{release}
17 Obsoletes:      python-django_registration < 0.6-2
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is a fairly simple user-registration application for Django,
23 designed to make allowing user signups as painless as possible. It
24 requires a functional installation of Django 1.3 or newer, but has no
25 other dependencies.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 rm -r docs/_build/html/.buildinfo
31
32 %build
33 %py_build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %py_install
38
39 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/registration/tests
40
41 # Language files; not under %{_datadir}, need to be handled manually
42 for a in $RPM_BUILD_ROOT%{py_sitescriptdir}/registration/locale/[a-z]*; do
43         # path file and lang
44         p=${a#$RPM_BUILD_ROOT} l=${a##*/}
45         echo "%lang($l) $p"
46 done >> %{name}.lang
47
48 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
49 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
50 %py_postclean
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files -f %{name}.lang
56 %defattr(644,root,root,755)
57 %doc LICENSE AUTHORS CHANGELOG README docs/*
58 %dir %{py_sitescriptdir}/registration
59 %{py_sitescriptdir}/registration/*.py[co]
60 %{py_sitescriptdir}/registration/backends
61 %{py_sitescriptdir}/registration/management
62 %dir %{py_sitescriptdir}/registration/locale
63 %{py_sitescriptdir}/django_registration-%{version}-py*.egg-info
This page took 0.532779 seconds and 3 git commands to generate.