]> git.pld-linux.org Git - SPECS.git/blob - python-dj_database_url.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / python-dj_database_url.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Use Database URLs in your Django Application
7 Summary(pl.UTF-8):      Korzystanie z URL-i do baz danych w aplikacji Django
8 Name:           python-dj_database_url
9 # keep 0.x here for python2 / django1..2 support
10 Version:        0.5.0
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/dj-database-url/
15 Source0:        https://files.pythonhosted.org/packages/source/d/dj-database-url/dj-database-url-%{version}.tar.gz
16 # Source0-md5:  eb9b3997e3a0ddfc38a25beef28f3b21
17 URL:            https://pypi.org/project/dj-database-url/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules >= 1:3.2
24 BuildRequires:  python3-setuptools
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python-modules >= 1:2.7
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module allows to utilize the 12factor inspired DATABASE_URL
34 environment variable to configure Django application.
35
36 %description -l pl.UTF-8
37 Ten moduł pozwala na konfigurowanie aplikacji Django przy użyciu
38 zmiennej środowiskowej DATABASE_URL, zainspirowanej przez 12factor.
39
40 %package -n python3-dj_database_url
41 Summary:        Use Database URLs in your Django Application
42 Summary(pl.UTF-8):      Korzystanie z URL-i do baz danych w aplikacji Django
43 Group:          Libraries/Python
44 Requires:       python3-modules >= 1:3.2
45
46 %description -n python3-dj_database_url
47 This module allows to utilize the 12factor inspired DATABASE_URL
48 environment variable to configure Django application.
49
50 %description -n python3-dj_database_url -l pl.UTF-8
51 Ten moduł pozwala na konfigurowanie aplikacji Django przy użyciu
52 zmiennej środowiskowej DATABASE_URL, zainspirowanej przez 12factor.
53
54 %prep
55 %setup -q -n dj-database-url-%{version}
56
57 %build
58 %if %{with python2}
59 %py_build
60 %endif
61
62 %if %{with python3}
63 %py3_build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %py_install
71
72 %py_postclean
73 %endif
74
75 %if %{with python3}
76 %py3_install
77 %endif
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %files
84 %defattr(644,root,root,755)
85 %doc LICENSE README.rst
86 %{py_sitescriptdir}/dj_database_url.py[co]
87 %{py_sitescriptdir}/dj_database_url-%{version}-py*.egg-info
88 %endif
89
90 %if %{with python3}
91 %files -n python3-dj_database_url
92 %defattr(644,root,root,755)
93 %doc LICENSE README.rst
94 %{py3_sitescriptdir}/dj_database_url.py
95 %{py3_sitescriptdir}/__pycache__/dj_database_url.cpython-*.py[co]
96 %{py3_sitescriptdir}/dj_database_url-%{version}-py*.egg-info
97 %endif
This page took 0.698415 seconds and 3 git commands to generate.