]> git.pld-linux.org Git - packages/python-dateutil.git/blob - python-dateutil.spec
- release 4 (by relup.sh)
[packages/python-dateutil.git] / python-dateutil.spec
1 %define         module dateutil
2 Summary:        Extensions to the standard datetime module
3 Summary(pl.UTF-8):      Rozszerzenia modułu datetime języka Python
4 Name:           python-dateutil
5 Version:        1.5
6 Release:        4
7 License:        BSD
8 Group:          Libraries/Python
9 Source0:        http://niemeyer.net/download/python-dateutil/python-%{module}-%{version}.tar.gz
10 # Source0-md5:  35f3732db3f2cc4afdc68a8533b60a52
11 Patch0:         system-zoneinfo.patch
12 URL:            http://niemeyer.net/python-dateutil
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 0.219
15 Requires:       tzdata
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The dateutil module provides powerful extensions to the standard
21 datetime module, available in Python 2.3+. Allows:
22 - computing of relative deltas (next month, next year, next monday,
23   last week of month, etc),
24 - computing of dates based on very flexible recurrence rules, using a
25   superset of the [WWW] iCalendar specification,
26 - parsing of RFC strings,
27 - peneric parsing of dates in almost any string format.
28
29 %description -l pl.UTF-8
30 Moduł dateutil jest potężnym rozszerzeniem standardowego modułu
31 datetime, dostępnego w Pythonie 2.3+. Pozwala na:
32 - obliczanie relatywnych różnic (następny miesiąc, rok, poniedziałek,
33   ostatni tydzień miesiąca itp.),
34 - obliczanie dat w oparciu o bardzo elastyczne rekurencyjne zasady, z
35   użyciem nadzbioru specyfikacji [WWW] iCalendar,
36 - analizę łańcuchow znakowych RFC,
37 - analizę dat w prawie każdym formacie.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42
43 %build
44 %{__python} setup.py build
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__python} setup.py install \
49         --skip-build \
50         --optimize=2 \
51         --root=$RPM_BUILD_ROOT \
52
53 %py_postclean
54
55 # NOTE: Not sure but seems zoneinfo is needed under windows only
56 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/dateutil/zoneinfo
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc LICENSE NEWS README
64 %{py_sitescriptdir}/dateutil
65 %{py_sitescriptdir}/python_dateutil-*.egg-info
This page took 0.053171 seconds and 4 git commands to generate.