]> git.pld-linux.org Git - packages/python-dateutil.git/blob - python-dateutil.spec
b26db02c11697128e324866cdebfcca8a7028a2a
[packages/python-dateutil.git] / python-dateutil.spec
1 %define         module dateutil
2 Summary:        Extensions to the standard datetime module
3 Summary(pl.UTF-8):      Rozszerzenia modułu datetime języka Python
4 Name:           python-dateutil
5 Version:        2.2
6 Release:        1
7 License:        BSD
8 Group:          Libraries/Python
9 Source0:        https://pypi.python.org/packages/source/p/python-dateutil/python-%{module}-%{version}.tar.gz
10 # Source0-md5:  c1f654d0ff7e33999380a8ba9783fd5c
11 Patch0:         system-zoneinfo.patch
12 URL:            http://labix.org/python-dateutil
13 BuildRequires:  python-modules >= 1:2.6
14 BuildRequires:  python-six
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 0.219
17 Requires:       python-six
18 Requires:       tzdata >= 2013h
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The dateutil module provides powerful extensions to the standard
24 datetime module, available in Python 2.3+. Allows:
25 - computing of relative deltas (next month, next year, next monday,
26   last week of month, etc),
27 - computing of dates based on very flexible recurrence rules, using a
28   superset of the [WWW] iCalendar specification,
29 - parsing of RFC strings,
30 - peneric parsing of dates in almost any string format.
31
32 %description -l pl.UTF-8
33 Moduł dateutil jest potężnym rozszerzeniem standardowego modułu
34 datetime, dostępnego w Pythonie 2.3+. Pozwala na:
35 - obliczanie relatywnych różnic (następny miesiąc, rok, poniedziałek,
36   ostatni tydzień miesiąca itp.),
37 - obliczanie dat w oparciu o bardzo elastyczne rekurencyjne zasady, z
38   użyciem nadzbioru specyfikacji [WWW] iCalendar,
39 - analizę łańcuchow znakowych RFC,
40 - analizę dat w prawie każdym formacie.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 %{__python} setup.py build
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %{__python} setup.py install \
52         --skip-build \
53         --optimize=2 \
54         --root=$RPM_BUILD_ROOT \
55
56 %py_postclean
57
58 # NOTE: Not sure but seems zoneinfo is needed under windows only
59 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/dateutil/zoneinfo
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc LICENSE NEWS README
67 %{py_sitescriptdir}/dateutil
68 %{py_sitescriptdir}/python_dateutil-*.egg-info
This page took 0.175243 seconds and 3 git commands to generate.