]> git.pld-linux.org Git - SPECS.git/blob - python-daemon.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-daemon.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 # Disabled tests as pidlockfile is not anymore in the lastest python-lockfile
5
6 %define         module  daemon
7 Summary:        Library to implement a well-behaved Unix daemon process
8 Name:           python-%{module}
9 Version:        1.6
10 Release:        4
11 License:        Python
12 Group:          Development/Languages
13 Source0:        http://pypi.python.org/packages/source/p/python-daemon/%{name}-%{version}.tar.gz
14 # Source0-md5:  c774eda27d6c5d80b42037826d29e523
15 URL:            http://pypi.python.org/pypi/python-daemon/
16 BuildRequires:  python-devel
17 BuildRequires:  python-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 BuildRequires:  sed >= 4.0
21 %if %{with tests}
22 BuildRequires:  python-lockfile
23 BuildRequires:  python-minimock
24 %endif
25 Requires:       python-lockfile
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This library implements the well-behaved daemon specification of PEP
31 3143, "Standard daemon process library".
32
33 %prep
34 %setup -q
35
36 %{__sed} -i -e '/^#!\//, 1d' daemon/version/version_info.py
37
38 %build
39 %py_build
40
41 # Test suite requires minimock and lockfile
42 %if %{with tests}
43 PYTHONPATH=$(pwd) nosetests-%{py_ver}
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %py_install
49
50 %py_postclean
51
52 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc LICENSE.PSF-2
60 %dir %{py_sitescriptdir}/daemon
61 %dir %{py_sitescriptdir}/daemon/version
62 %{py_sitescriptdir}/daemon/*.py[co]
63 %{py_sitescriptdir}/daemon/version/*.py[co]
64 %{py_sitescriptdir}/python_daemon-%{version}-py%{py_ver}.egg-info
This page took 0.137437 seconds and 3 git commands to generate.