]> git.pld-linux.org Git - SPECS.git/blob - python-coinkit.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-coinkit.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5
6 %define         module  coinkit
7 Summary:        Tools for Bitcoin and other cryptocurrencies
8 Summary(pl.UTF-8):      Narzędzia do Bitcoinów i innych kryptowalut
9 Name:           python-%{module}
10 Version:        0.3
11 Release:        10
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://github.com/halfmoonlabs/coinkit/releases
15 #TODO: use      https://github.com/halfmoonlabs/coinkit/archive/v%{version}/%{name}-%{version}.tar.gz
16 Source0:        https://github.com/halfmoonlabs/coinkit/archive/v%{version}.tar.gz
17 # Source0-md5:  2e5bd02391fa38766a5644e7abfa9750
18 URL:            https://github.com/halfmoonlabs/coinkit
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildRequires:  rpm-pythonprov
21 %if %{with python2}
22 BuildRequires:  python-devel
23 BuildRequires:  python-modules
24 BuildRequires:  python-setuptools
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-2to3
28 BuildRequires:  python3-devel
29 BuildRequires:  python3-modules
30 BuildRequires:  python3-setuptools
31 %endif
32 Requires:       python
33 Requires:       python-ecdsa >= 0.10
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Tools for Bitcoin and other cryptocurrencies.
39
40 %description -l pl.UTF-8
41 Narzędzia do Bitcoinów i innych kryptowalut.
42
43 %package -n python3-%{module}
44 Summary:        Tools for Bitcoin and other cryptocurrencies
45 Summary(pl.UTF-8):      Narzędzia do Bitcoinów i innych kryptowalut
46 Group:          Libraries/Python
47 Requires:       python3
48 Requires:       python3-ecdsa >= 0.10
49
50 %description -n python3-%{module}
51 Tools for Bitcoin and other cryptocurrencies.
52
53 %description -n python3-%{module} -l pl.UTF-8
54 Narzędzia do Bitcoinów i innych kryptowalut.
55
56 %prep
57 %setup -q -n coinkit-%{version}
58
59 %build
60 %if %{with python2}
61 %py_build
62 %endif
63
64 %if %{with python3}
65 %py3_build
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %if %{with python2}
72 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
73 %py_install
74 %endif
75
76 %if %{with python3}
77 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
78 %py3_install
79 %endif
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %if %{with python2}
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS README.md
88 %{py_sitescriptdir}/%{module}
89 %{py_sitescriptdir}/*egg-info
90 %{_examplesdir}/python-%{module}-%{version}
91 %endif
92
93 %if %{with python3}
94 %files -n python3-%{module}
95 %defattr(644,root,root,755)
96 %doc AUTHORS README.md
97 %{py3_sitescriptdir}/%{module}
98 %{py3_sitescriptdir}/*egg-info
99 %{_examplesdir}/python3-%{module}-%{version}
100 %endif
This page took 0.160565 seconds and 3 git commands to generate.