]> git.pld-linux.org Git - SPECS.git/blob - python-cloudpickle.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-cloudpickle.spec
1 # NOTE: for versions >= 1.4.0 (for python 3.5+) see python3-cloudpickle.spec
2 #
3 # Conditional build:
4 %bcond_with     tests   # unit tests (some incompatible with python2, few failing on python3.8)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_with     python3 # CPython 3.x module (built from python3-cloudpickle.spec)
7
8 Summary:        Extended pickling support for Python objects
9 Summary(pl.UTF-8):      Rozszerzona obsługa operacji pickle dla obiektów pythonowych
10 Name:           python-cloudpickle
11 # keep 1.3.x here for python2 support
12 Version:        1.3.0
13 Release:        1
14 License:        BSD
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/cloudpickle/
17 Source0:        https://files.pythonhosted.org/packages/source/c/cloudpickle/cloudpickle-%{version}.tar.gz
18 # Source0-md5:  625d9c80e1b4f2a3dea01f1b4c149511
19 URL:            https://pypi.org/project/cloudpickle/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-numpy
25 BuildRequires:  python-pytest
26 BuildRequires:  python-scipy
27 %endif
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-modules >= 1:3.5
31 BuildRequires:  python3-setuptools
32 %if %{with tests}
33 BuildRequires:  python3-numpy
34 BuildRequires:  python3-pytest
35 BuildRequires:  python3-scipy
36 %endif
37 %endif
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.714
40 Requires:       python-modules >= 1:2.7
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 cloudpickle makes it possible to serialize Python constructs not
46 supported by the default pickle module from the Python standard
47 library.
48
49 cloudpickle is especially useful for cluster computing where Python
50 code is shipped over the network to execute on remote hosts, possibly
51 close to the data.
52
53 Among other things, cloudpickle supports pickling for lambda functions
54 along with functions and classes defined interactively in the __main__
55 module (for instance in a script, a shell or a Jupyter notebook).
56
57 %description -l pl.UTF-8
58 cloudpickle pozwala serializować konstrukcje pythonowe nie obsługiwane
59 domyślnie przez moduł pickle z biblioteki standardowej Pythona.
60
61 cloudpickle jest przydatne szczególnie przy obliczeniach klastrowych,
62 gdzie kod pythonowy jest rozmieszczony po sieci, aby wykonywał się na
63 zdalnych maszynach, możliwie blisko danych.
64
65 cloudpickle obsługuje m.in. operacje pickle na funkcjach lambda oraz
66 funkcjach lub klasach definiowanych interaktywnie w module __main__
67 (np. w skrypcie, z powłoki lub w postaci Jupyter notebook).
68
69 %package -n python3-cloudpickle
70 Summary:        Extended pickling support for Python objects
71 Summary(pl.UTF-8):      Rozszerzona obsługa operacji pickle dla obiektów pythonowych
72 Group:          Libraries/Python
73 Requires:       python3-modules >= 1:3.5
74
75 %description -n python3-cloudpickle
76 cloudpickle makes it possible to serialize Python constructs not
77 supported by the default pickle module from the Python standard
78 library.
79
80 cloudpickle is especially useful for cluster computing where Python
81 code is shipped over the network to execute on remote hosts, possibly
82 close to the data.
83
84 Among other things, cloudpickle supports pickling for lambda functions
85 along with functions and classes defined interactively in the __main__
86 module (for instance in a script, a shell or a Jupyter notebook).
87
88 %description -n python3-cloudpickle -l pl.UTF-8
89 cloudpickle pozwala serializować konstrukcje pythonowe nie obsługiwane
90 domyślnie przez moduł pickle z biblioteki standardowej Pythona.
91
92 cloudpickle jest przydatne szczególnie przy obliczeniach klastrowych,
93 gdzie kod pythonowy jest rozmieszczony po sieci, aby wykonywał się na
94 zdalnych maszynach, możliwie blisko danych.
95
96 cloudpickle obsługuje m.in. operacje pickle na funkcjach lambda oraz
97 funkcjach lub klasach definiowanych interaktywnie w module __main__
98 (np. w skrypcie, z powłoki lub w postaci Jupyter notebook).
99
100 %prep
101 %setup -q -n cloudpickle-%{version}
102
103 %build
104 %if %{with python2}
105 %py_build %{?with_tests:test}
106 %endif
107
108 %if %{with python3}
109 %py3_build %{?with_tests:test}
110 %endif
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %if %{with python2}
116 %py_install
117
118 %py_postclean
119 %endif
120
121 %if %{with python3}
122 %py3_install
123 %endif
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %if %{with python2}
129 %files
130 %defattr(644,root,root,755)
131 %doc LICENSE README.md
132 %{py_sitescriptdir}/cloudpickle
133 %{py_sitescriptdir}/cloudpickle-%{version}-py*.egg-info
134 %endif
135
136 %if %{with python3}
137 %files -n python3-cloudpickle
138 %defattr(644,root,root,755)
139 %doc LICENSE README.md
140 %{py3_sitescriptdir}/cloudpickle
141 %{py3_sitescriptdir}/cloudpickle-%{version}-py*.egg-info
142 %endif
This page took 1.647161 seconds and 3 git commands to generate.