]> git.pld-linux.org Git - SPECS.git/blob - python-cloud_sptheme.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-cloud_sptheme.spec
1 # TODO: docs (requires custom sphinxcontrib-fulltoc, see docs/requirements.txt)
2 #
3 # Conditional build:
4 %bcond_with     doc     # Sphinx documentation
5 %bcond_without  tests   # unit tests
6 %bcond_without  python2 # CPython 2.x module
7 %bcond_without  python3 # CPython 3.x module
8
9 Summary:        "Cloud" Sphinx Theme
10 Summary(pl.UTF-8):      Motyw "Cloud" dla Sphinksa
11 Name:           python-cloud_sptheme
12 Version:        1.9.4
13 Release:        3
14 License:        BSD
15 Group:          Libraries/Python
16 # if pypi:
17 #Source0Download: https://pypi.org/simple/cloud_sptheme/
18 Source0:        https://files.pythonhosted.org/packages/source/c/cloud_sptheme/cloud_sptheme-%{version}.tar.gz
19 # Source0-md5:  9a74d8609cd2c640c3a2ec459e5438dc
20 Patch0:         %{name}-mock.patch
21 URL:            https://pypi.org/project/cloud_sptheme/
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.714
24 %if %{with python2}
25 BuildRequires:  python-modules >= 1:2.6
26 BuildRequires:  python-setuptools
27 %if %{with tests}
28 BuildRequires:  python-Sphinx >= 1.4
29 BuildRequires:  python-mock
30 %endif
31 %endif
32 %if %{with python3}
33 BuildRequires:  python3-modules >= 1:3.3
34 BuildRequires:  python3-setuptools
35 %if %{with tests}
36 BuildRequires:  python3-Sphinx >= 1.4
37 %endif
38 %endif
39 %if %{with doc}
40 BuildRequires:  sphinx-pdg
41 # python-sphinxcontrib-fulltoc
42 %endif
43 Requires:       python-modules >= 1:2.6
44 BuildArch:      noarch
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 This is a small package containing a Sphinx theme named "Cloud", along
49 with some related Sphinx extensions.
50
51 %description -l pl.UTF-8
52 Ten mały pakiet zawiera motyw Sphinksa "Cloud" wraz z kilkoma
53 powiązanymi rozszerzeniami Sphinksa.
54
55 %package -n python3-cloud_sptheme
56 Summary:        "Cloud" Sphinx Theme
57 Summary(pl.UTF-8):      Motyw "Cloud" dla Sphinksa
58 Group:          Libraries/Python
59 Requires:       python3-modules >= 1:3.3
60
61 %description -n python3-cloud_sptheme
62 This is a small package containing a Sphinx theme named "Cloud", along
63 with some related Sphinx extensions.
64
65 %description -n python3-cloud_sptheme -l pl.UTF-8
66 Ten mały pakiet zawiera motyw Sphinksa "Cloud" wraz z kilkoma
67 powiązanymi rozszerzeniami Sphinksa.
68
69 %package apidocs
70 Summary:        API documentation for Python cloud_sptheme module
71 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona cloud_sptheme
72 Group:          Documentation
73
74 %description apidocs
75 API documentation for Python cloud_sptheme module.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API modułu Pythona cloud_sptheme.
79
80 %prep
81 %setup -q -n cloud_sptheme-%{version}
82 %patch0 -p1
83
84 %build
85 %if %{with python2}
86 %py_build %{?with_tests:test}
87 %endif
88
89 %if %{with python3}
90 %py3_build %{?with_tests:test}
91 %endif
92
93 %if %{with doc}
94 %{__make} -C docs -j1 html
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %if %{with python2}
101 %py_install
102
103 %py_postclean
104 %endif
105
106 %if %{with python3}
107 %py3_install
108 %endif
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %if %{with python2}
114 %files
115 %defattr(644,root,root,755)
116 %doc CHANGES LICENSE README
117 %{py_sitescriptdir}/cloud_sptheme
118 %{py_sitescriptdir}/cloud_sptheme-%{version}-py*.egg-info
119 %endif
120
121 %if %{with python3}
122 %files -n python3-cloud_sptheme
123 %defattr(644,root,root,755)
124 %doc CHANGES LICENSE README
125 %{py3_sitescriptdir}/cloud_sptheme
126 %{py3_sitescriptdir}/cloud_sptheme-%{version}-py*.egg-info
127 %endif
128
129 %if %{with doc}
130 %files apidocs
131 %defattr(644,root,root,755)
132 %doc docs/_build/html/*
133 %endif
This page took 0.93559 seconds and 3 git commands to generate.