]> git.pld-linux.org Git - packages/python-cherrypy.git/blob - python-cherrypy.spec
- encode spec in UTF-8
[packages/python-cherrypy.git] / python-cherrypy.spec
1 %define         fname   CherryPy
2 %define         module  cherrypy
3 #
4 Summary:        A pythonic, object-oriented web development framework
5 Summary(pl.UTF-8):   Pythonowy, zorientowany obiektowo szkielet do tworzenia WWW
6 Name:           python-%{module}
7 Version:        2.2.1
8 Release:        2
9 License:        BSD
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/cherrypy/%{fname}-%{version}.tar.gz
12 # Source0-md5:  14bf17b0706bc480342cb8fcfaed74cd
13 Patch0:         %{name}-autoreload.patch
14 URL:            http://www.cherrypy.org
15 BuildRequires:  python >= 1:2.5
16 %pyrequires_eq  python-modules
17 Requires:       python-devel-tools
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 CherryPy is a pythonic, object-oriented web development framework.
23
24 CherryPy allows developers to build web applications in much the same
25 way they would build any other object-oriented Python program. This
26 usually results in smaller source code developed in less time.
27
28 CherryPy is now more than three years old and it is has proven very
29 fast and stable. It is being used in production by many sites, from
30 the simplest ones to the most demanding ones.
31
32 Oh, and most importantly: CherryPy is fun to work with :-)
33
34 %description -l pl.UTF-8
35 CherryPy to pythonowy, obiektowo zorientowany szkielet do tworzenia
36 WWW.
37
38 CherryPy pozwala programistom tworzyć aplikacje WWW w sposób bardzo
39 podobny do tworzenia każdego innego obiektowo zorientowanego programu
40 w Pythonie. Wynikiem tego jest zwykle mniejszy kod źródłowy stworzony
41 w krótszym czasie.
42
43 CherryPy ma już nieco ponad trzy lata i okazał się być bardzo szybki i
44 stabilny. Jest używany produkcyjnie przez wiele serwisów, od
45 najprostszych do bardziej wymagających.
46
47 I najważniejsze - praca z CherryPy jest zabawą :-)
48
49 %package examples
50 Summary:        Example files for CherryPy
51 Summary(pl.UTF-8):   Pliki przykładów dla CherryPy
52 Group:          Development/Languages/Python
53 Requires:       %{name} = %{version}-%{release}
54
55 %description examples
56 Example files for CherryPy.
57
58 %description examples -l pl.UTF-8
59 Pliki przykładów dla CherryPy.
60
61 %prep
62 %setup -q -n %{fname}-%{version}
63 %patch0 -p1
64
65 %build
66 python setup.py build
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 python setup.py install \
73         --root=$RPM_BUILD_ROOT \
74         --optimize=2
75
76 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tutorial
77
78 find $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/ -name \*.py | xargs rm -f
79
80 cp -r cherrypy/tutorial $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGELOG.txt CHERRYPYTEAM.txt README.txt
88 %{py_sitescriptdir}/%{module}
89 %{py_sitescriptdir}/CherryPy*
90
91 %files examples
92 %defattr(644,root,root,755)
93 %{_examplesdir}/%{name}-%{version}
This page took 0.056276 seconds and 3 git commands to generate.