]> git.pld-linux.org Git - SPECS.git/blob - python-chameleon.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-chameleon.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  chameleon
6 Summary:        Fast HTML/XML Template Compiler
7 Name:           python-%{module}
8 Version:        2.11
9 Release:        3
10 License:        BSD-derived (http://www.repoze.org/LICENSE.txt)
11 Group:          Libraries/Python
12 Source0:        http://pypi.python.org/packages/source/C/Chameleon/Chameleon-%{version}.tar.gz
13 # Source0-md5:  df72458bf3dd26a744dcff5ad555c34b
14 URL:            http://pypi.python.org/pypi/Chameleon
15 BuildRequires:  python-distribute
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 Requires:       python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Chameleon is an HTML/XML template engine for Python. It uses the page
24 templates language.
25
26 %prep
27 %setup -q -n Chameleon-%{version}
28
29 %build
30 %py_build
31
32 %{?with_tests:%{__python} setup.py test}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 %py_install
37
38 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
39
40 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
41 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
42 %py_postclean
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc CHANGES.rst COPYRIGHT.txt LICENSE.txt README.rst
50 %dir %{py_sitescriptdir}/%{module}
51 %{py_sitescriptdir}/%{module}/*.py[co]
52 %{py_sitescriptdir}/%{module}/zpt
53 %{py_sitescriptdir}/Chameleon-%{version}-py*.egg-info
This page took 0.69112 seconds and 3 git commands to generate.