]> git.pld-linux.org Git - SPECS.git/blob - python-boto.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / python-boto.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define module boto
9 Summary:        An integrated interface to infrastructural services offered by Amazon Web Services
10 Summary(pl.UTF-8):      Zintegrowany interfejs do usług infrastruktury oferowanych przez usługi WWW Amazon
11 Name:           python-%{module}
12 Version:        2.49.0
13 Release:        6
14 License:        MIT
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/boto/
17 Source0:        https://files.pythonhosted.org/packages/source/b/boto/boto-%{version}.tar.gz
18 # Source0-md5:  e9b79f80198da059d9a8055a5352fd6d
19 Patch0:         %{name}-mock.patch
20 Patch1:         %{name}-py3.patch
21 # https://github.com/boto/boto/pull/3086 (unbundle six)
22 Patch2:         boto-devendor.patch
23 # https://github.com/boto/boto/pull/3472
24 Patch3:         boto-nat-gateway.patch
25 # https://github.com/boto/boto/pull/3506
26 # https://github.com/boto/boto/pull/3508
27 Patch4:         boto-retry-float.patch
28 # https://github.com/boto/boto/pull/3332
29 Patch5:         boto-aws-exec-read.patch
30 # https://github.com/boto/boto/pull/3077
31 # https://github.com/boto/boto/pull/3131
32 Patch6:         boto-instance-attributes.patch
33 # https://github.com/boto/boto/pull/2882
34 Patch7:         boto-multi-vpc-zone.patch
35 # https://github.com/boto/boto/pull/2875
36 Patch8:         boto-s3-requestlog.patch
37 # https://github.com/boto/boto/pull/2866
38 Patch9:         boto-route53-no-resourcepath.patch
39 # https://github.com/boto/boto/pull/3111
40 Patch10:        boto-modifysubnetattribute.patch
41 URL:            https://github.com/boto/boto
42 %if %{with python2}
43 BuildRequires:  python-modules >= 1:2.6
44 BuildRequires:  python-setuptools
45 %if %{with tests}
46 BuildRequires:  python-httpretty
47 BuildRequires:  python-mock
48 BuildRequires:  python-nose
49 %endif
50 %endif
51 %if %{with python3}
52 BuildRequires:  python3-modules >= 1:3.3
53 BuildRequires:  python3-setuptools
54 %if %{with tests}
55 BuildRequires:  python3-httpretty
56 BuildRequires:  python3-nose
57 %endif
58 %endif
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  rpmbuild(macros) >= 1.714
61 %if %{with doc}
62 BuildRequires:  sphinx-pdg-2
63 %endif
64 Requires:       python-modules >= 1:2.6
65 BuildArch:      noarch
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 An integrated interface to current and future infrastructural services
70 offered by Amazon Web Services.
71
72 %description -l pl.UTF-8
73 Zintegrowany interfejs do aktualnych i przyszłych usług infrastruktury
74 oferowanych przez usługi WWW Amazon.
75
76 %package -n python3-%{module}
77 Summary:        An integrated interface to infrastructural services offered by Amazon Web Services
78 Summary(pl.UTF-8):      Zintegrowany interfejs do usług infrastruktury oferowanych przez usługi WWW Amazon
79 Group:          Libraries/Python
80 Requires:       python3-modules >= 1:3.3
81
82 %description -n python3-%{module}
83 An integrated interface to current and future infrastructural services
84 offered by Amazon Web Services.
85
86 %description -n python3-%{module} -l pl.UTF-8
87 Zintegrowany interfejs do aktualnych i przyszłych usług infrastruktury
88 oferowanych przez usługi WWW Amazon.
89
90 %package -n boto
91 Summary:        Python utilities for Amazon Web Services
92 Summary(pl.UTF-8):      Pythonowe narzędzia do usług AWS
93 Group:          Applications/Networking
94 %if %{with python3}
95 Requires:       python3-%{module} = %{version}-%{release}
96 %else
97 Requires:       %{name} = %{version}-%{release}
98 %endif
99
100 %description -n boto
101 Boto is an integrated Python interface to current and future
102 infrastructural services offered by Amazon Web Services.
103
104 This package includes sample utilities implemented with this API.
105
106 %description -n boto -l pl.UTF-8
107 Boto to zintegrowany interfejs do aktualnych i przyszłych usług
108 infrastruktury oferowanych przez usługi AWS (Amazon WWW Services).
109
110 Ten pakiet zawiera przykładowe narzędzia zaimplementowane przy użyciu
111 API boto.
112
113 %package apidocs
114 Summary:        API documentation for Python boto module
115 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona boto
116 Group:          Documentation
117
118 %description apidocs
119 API documentation for Python boto module.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API modułu Pythona boto.
123
124 %prep
125 %setup -q -n %{module}-%{version}
126 %patch0 -p1
127 %patch1 -p1
128 %patch2 -p1
129 %patch3 -p1
130 %patch4 -p1
131 %patch5 -p1
132 %patch6 -p1
133 %patch7 -p1
134 %patch8 -p1
135 %patch9 -p1
136 %patch10 -p1
137
138 %build
139 %if %{with python2}
140 %py_build
141
142 %if %{with tests}
143 nosetests-%{py_ver} tests/unit -a '!notdefault'
144 %endif
145 %endif
146
147 %if %{with python3}
148 %py3_build
149
150 %if %{with tests}
151 nosetests-%{py3_ver} tests/unit -a '!notdefault'
152 %endif
153 %endif
154
155 %if %{with doc}
156 # docs are not ready for python3
157 PYTHONPATH=$(pwd) \
158 %{__make} -C docs html \
159         SPHINXBUILD=sphinx-build-2
160 %endif
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %if %{with python2}
166 %py_install
167
168 for bin in asadmin bundle_image cfadmin cq cwutil dynamodb_dump dynamodb_load elbadmin \
169            fetch_file glacier instance_events kill_instance launch_instance list_instances \
170            lss3 mturk pyami_sendmail route53 s3put sdbadmin taskadmin ; do
171         %{__mv} $RPM_BUILD_ROOT%{_bindir}/${bin} $RPM_BUILD_ROOT%{_bindir}/${bin}-2
172 %if %{without python3}
173         ln -sf ${bin}-2 $RPM_BUILD_ROOT%{_bindir}/${bin}
174 %endif
175 done
176
177 %py_postclean
178 %endif
179
180 %if %{with python3}
181 %py3_install
182
183 for bin in asadmin bundle_image cfadmin cq cwutil dynamodb_dump dynamodb_load elbadmin \
184            fetch_file glacier instance_events kill_instance launch_instance list_instances \
185            lss3 mturk pyami_sendmail route53 s3put sdbadmin taskadmin ; do
186         %{__mv} $RPM_BUILD_ROOT%{_bindir}/${bin} $RPM_BUILD_ROOT%{_bindir}/${bin}-3
187         ln -sf ${bin}-3 $RPM_BUILD_ROOT%{_bindir}/${bin}
188 done
189 %endif
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %if %{with python2}
195 %files
196 %defattr(644,root,root,755)
197 %doc README.rst
198 %attr(755,root,root) %{_bindir}/asadmin-2
199 %attr(755,root,root) %{_bindir}/bundle_image-2
200 %attr(755,root,root) %{_bindir}/cfadmin-2
201 %attr(755,root,root) %{_bindir}/cq-2
202 %attr(755,root,root) %{_bindir}/cwutil-2
203 %attr(755,root,root) %{_bindir}/dynamodb_dump-2
204 %attr(755,root,root) %{_bindir}/dynamodb_load-2
205 %attr(755,root,root) %{_bindir}/elbadmin-2
206 %attr(755,root,root) %{_bindir}/fetch_file-2
207 %attr(755,root,root) %{_bindir}/glacier-2
208 %attr(755,root,root) %{_bindir}/instance_events-2
209 %attr(755,root,root) %{_bindir}/kill_instance-2
210 %attr(755,root,root) %{_bindir}/launch_instance-2
211 %attr(755,root,root) %{_bindir}/list_instances-2
212 %attr(755,root,root) %{_bindir}/lss3-2
213 %attr(755,root,root) %{_bindir}/mturk-2
214 %attr(755,root,root) %{_bindir}/pyami_sendmail-2
215 %attr(755,root,root) %{_bindir}/route53-2
216 %attr(755,root,root) %{_bindir}/s3put-2
217 %attr(755,root,root) %{_bindir}/sdbadmin-2
218 %attr(755,root,root) %{_bindir}/taskadmin-2
219 %{py_sitescriptdir}/boto
220 %{py_sitescriptdir}/boto-%{version}-py*.egg-info
221 %endif
222
223 %if %{with python3}
224 %files -n python3-%{module}
225 %defattr(644,root,root,755)
226 %doc README.rst
227 %attr(755,root,root) %{_bindir}/asadmin-3
228 %attr(755,root,root) %{_bindir}/bundle_image-3
229 %attr(755,root,root) %{_bindir}/cfadmin-3
230 %attr(755,root,root) %{_bindir}/cq-3
231 %attr(755,root,root) %{_bindir}/cwutil-3
232 %attr(755,root,root) %{_bindir}/dynamodb_dump-3
233 %attr(755,root,root) %{_bindir}/dynamodb_load-3
234 %attr(755,root,root) %{_bindir}/elbadmin-3
235 %attr(755,root,root) %{_bindir}/fetch_file-3
236 %attr(755,root,root) %{_bindir}/glacier-3
237 %attr(755,root,root) %{_bindir}/instance_events-3
238 %attr(755,root,root) %{_bindir}/kill_instance-3
239 %attr(755,root,root) %{_bindir}/launch_instance-3
240 %attr(755,root,root) %{_bindir}/list_instances-3
241 %attr(755,root,root) %{_bindir}/lss3-3
242 %attr(755,root,root) %{_bindir}/mturk-3
243 %attr(755,root,root) %{_bindir}/pyami_sendmail-3
244 %attr(755,root,root) %{_bindir}/route53-3
245 %attr(755,root,root) %{_bindir}/s3put-3
246 %attr(755,root,root) %{_bindir}/sdbadmin-3
247 %attr(755,root,root) %{_bindir}/taskadmin-3
248 %{py3_sitescriptdir}/boto
249 %{py3_sitescriptdir}/boto-%{version}-py*.egg-info
250 %endif
251
252 %files -n boto
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_bindir}/asadmin
255 %attr(755,root,root) %{_bindir}/bundle_image
256 %attr(755,root,root) %{_bindir}/cfadmin
257 %attr(755,root,root) %{_bindir}/cq
258 %attr(755,root,root) %{_bindir}/cwutil
259 %attr(755,root,root) %{_bindir}/dynamodb_dump
260 %attr(755,root,root) %{_bindir}/dynamodb_load
261 %attr(755,root,root) %{_bindir}/elbadmin
262 %attr(755,root,root) %{_bindir}/fetch_file
263 %attr(755,root,root) %{_bindir}/glacier
264 %attr(755,root,root) %{_bindir}/instance_events
265 %attr(755,root,root) %{_bindir}/kill_instance
266 %attr(755,root,root) %{_bindir}/launch_instance
267 %attr(755,root,root) %{_bindir}/list_instances
268 %attr(755,root,root) %{_bindir}/lss3
269 %attr(755,root,root) %{_bindir}/mturk
270 %attr(755,root,root) %{_bindir}/pyami_sendmail
271 %attr(755,root,root) %{_bindir}/route53
272 %attr(755,root,root) %{_bindir}/s3put
273 %attr(755,root,root) %{_bindir}/sdbadmin
274 %attr(755,root,root) %{_bindir}/taskadmin
275
276 %if %{with doc}
277 %files apidocs
278 %defattr(644,root,root,755)
279 %doc docs/build/html/{_static,migrations,ref,releasenotes,*.html,*.js}
280 %endif
This page took 2.334326 seconds and 3 git commands to generate.