]> git.pld-linux.org Git - SPECS.git/blob - python-aws_xray_sdk.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-aws_xray_sdk.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        AWS X-Ray SDK for Python 2
8 Summary(pl.UTF-8):      SDK AWS X-Ray dla Pythona 2
9 Name:           python-aws_xray_sdk
10 Version:        2.6.0
11 Release:        1
12 License:        Apache v2.0
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/aws-xray-sdk/
15 Source0:        https://files.pythonhosted.org/packages/source/a/aws-xray-sdk/aws-xray-sdk-%{version}.tar.gz
16 # Source0-md5:  0dde2a6df0c1ce452d6fff5ea485a376
17 Patch0:         %{name}-future.patch
18 URL:            https://pypi.org/project/aws-xray-sdk/
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-botocore >= 1.11.3
24 BuildRequires:  python-enum34
25 BuildRequires:  python-future
26 BuildRequires:  python-jsonpickle
27 BuildRequires:  python-wrapt
28 %endif
29 %endif
30 %if %{with python3}
31 BuildRequires:  python3-modules >= 1:3.4
32 BuildRequires:  python3-setuptools
33 %if %{with tests}
34 BuildRequires:  python3-botocore >= 1.11.3
35 BuildRequires:  python3-jsonpickle
36 BuildRequires:  python3-wrapt
37 %endif
38 %endif
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.714
41 Requires:       python-modules >= 1:2.7
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The AWS X-Ray SDK for Python enables Python developers to record and
47 emit information from within their applications to the AWS X-Ray
48 service.
49
50 %description -l pl.UTF-8
51 AWS X-Ray SDK dla Pythona pozwala programistom Pythona zapisywać i
52 emitować z aplikacji informacje do usługi AWS X-Ray.
53
54 %package -n python3-aws_xray_sdk
55 Summary:        AWS X-Ray SDK for Python 3
56 Summary(pl.UTF-8):      SDK AWS X-Ray dla Pythona 3
57 Group:          Libraries/Python
58 Requires:       python3-modules >= 1:3.4
59
60 %description -n python3-aws_xray_sdk
61 The AWS X-Ray SDK for Python enables Python developers to record and
62 emit information from within their applications to the AWS X-Ray
63 service.
64
65 %description -n python3-aws_xray_sdk -l pl.UTF-8
66 AWS X-Ray SDK dla Pythona pozwala programistom Pythona zapisywać i
67 emitować z aplikacji informacje do usługi AWS X-Ray.
68
69 %prep
70 %setup -q -n aws-xray-sdk-%{version}
71 %patch0 -p1
72
73 %build
74 %if %{with python2}
75 %py_build
76 %endif
77
78 %if %{with python3}
79 %py3_build
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with python2}
86 %py_install
87
88 %py_postclean
89 %endif
90
91 %if %{with python3}
92 %py3_install
93 %endif
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %if %{with python2}
99 %files
100 %defattr(644,root,root,755)
101 %doc README.md
102 %{py_sitescriptdir}/aws_xray_sdk
103 %{py_sitescriptdir}/aws_xray_sdk-%{version}-py*.egg-info
104 %endif
105
106 %if %{with python3}
107 %files -n python3-aws_xray_sdk
108 %defattr(644,root,root,755)
109 %doc README.md
110 %{py3_sitescriptdir}/aws_xray_sdk
111 %{py3_sitescriptdir}/aws_xray_sdk-%{version}-py*.egg-info
112 %endif
This page took 0.448476 seconds and 3 git commands to generate.